bfs-catch that cow

在一条数轴上, Farmer John 从 N 点出发,使用步行或瞬移的方式追赶位于 K 点的逃逸奶牛。步行可以让他每分钟向左或右移动一个单位距离,而瞬移则能让他瞬间到达当前位置的两倍远距离。本篇介绍如何通过这两种方式以最短的时间抓到不动的奶牛。
摘要由CSDN通过智能技术生成

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
#include <iostream>
#include<cstring>
#include<queue>
#include<cstdlib>
using namespace std;
int n,k;
const int maxn=100005;
int vis[maxn];
struct node
{
    int x;
    int step;
    node(int xx,int s):x(xx),step(s) { }    //赋值方式
};
queue<node>q;
int main()
{
    cin>>n>>k;
    memset(vis,0,sizeof(vis));
    q.push(node(n,0));
    vis[n]=1;
    while(!q.empty())
    {
        node s=q.front();   //取出一个
        if(s.x==k)
        {
            cout<<s.step<<endl;
            return 0;
        }
        else
        {
            if(s.x-1>=0&&!vis[s.x-1])
            {
                q.push(node(s.x-1,s.step+1));   //入队 
                vis[s.x-1]=1;
            }
            if(s.x+1<=maxn&&!vis[s.x+1])
            {
                q.push(node(s.x+1,s.step+1));
                vis[s.x+1]=1;
            }
            if(s.x*2<=maxn&&!vis[s.x*2])
            {
                q.push(node(s.x*2,s.step+1));
                vis[s.x*2]=1;
            }
            q.pop();  // 出队
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值