kuangbin 简单搜索C题

Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17

Sample Output
4

题意:

这题其实就是bfs队列维护一下就好了。注意数组不要越界。RE了好几次
必须2*c<=100000&&!num[2*c]这么写
!num[2*c]&&2*c<=100000就可能会越界

代码:

#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
using namespace std;
const int maxn = 100000+100;
typedef long long LL;
LL num[maxn];

LL n,k;

int main()
{
    while(cin>>n>>k)
    {

        queue<LL> que;
        que.push(n);
        num[n]=1;
        LL ans=0;
        memset(num,0,sizeof(num));
        while(que.size())
        {
            LL c = que.front();
            if(c==k)
            {
                ans = num[c];
                break;
            }
            que.pop();
            if(c-1>=0&&!num[c-1])
            {
                num[c-1]=num[c]+1;
                que.push(c-1);
            }
            if(c+1<=100000&&!num[c+1])
            {
                num[c+1]=num[c]+1;
                que.push(c+1);

            }
            if(2*c<=100000&&!num[2*c])
            {
                num[2*c]=num[c]+1;
                que.push(2*c);
            }
        }
        printf("%lld\n",ans-1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值