问题及代码
Description
输入一个字符串,将其按给定的长度n格式化并输出,若n=0,则输出原字符串
Input
输入一个字符串
Output
格式化并输出
Sample Input
asdfasdf
3
Sample Output
asd
fas
df
/*烟台大学计算机学院 2016
作者: 马春澎
完成日期:2016年12月10日 */
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
int m,n,i;
char s[80];
gets(s);
scanf("%d",&n);
m=strlen(s);
for(i=0; i<m; i++)
{
if((i+1)%n!=0)
{
printf("%c",s[i]);
}
else
{ printf("%c",s[i]);
printf("\n");
}
}
return 0;
}
运算结果
知识点总结
字符串的应用
学习心得
输出的时候可以一个一个的输出当输出n个时换行,继续输出。