哈理工OJ 1251 【带坑的快速幂】【好题】

Marshal's Confusion III
Time Limit: 3000 MSMemory Limit: 65536 K
Total Submit: 251(67 users)Total Accepted: 81(56 users)Rating: Special Judge: No
Description
Marshallike to solve acm problems.But they are very busy, one day they meet a problem. Given three intergers a,b,c, the task is to compute a^(b^c))%317000011. so the turn to you for help. 
Input
The first line contains an integer T which stands for the number of test cases. Each case consists of three integer a, b, c seperated by a space in a single line. 1 <= a,b,c <= 100000
Output
For each case, print a^(b^c)%317000011 in a single line.
Sample Input
2
1 1 1
2 2 2
Sample Output

1
16

Author
王勇

这里思路很简单,对b,c进行一次快速幂求余,然后得到一个值假设为ans,然后a,ans再来一次快速幂求余搞定整个题~。然后我就开开心心的用这个方法去做,怎么交怎么WA,怎么写怎么改都是WA 。这个时候内心近乎于崩溃。

这个时候坑点出来了:如果b^c得到的值是,317000011,我用快速幂求余的方法,得到的值是0啊,然后a^0永远都是1啊,那不对啊。所以这个时候我开始用草纸举栗子,发现有一个结论,如果mod【这里题目给的是317000011】是个奇数,那么就有这样的一个结论:如果b^c==mod,那么a^(b^c)==a;

然后排除了这个坑,我们就能开开森森的做题啦~

#include<stdio.h>
#include<string.h>
using namespace std;
const long long int  mod=317000011;
long long int kuaisumi(long long int a,long long int b,int mod)
{
    long long int tmp=a%mod;
    long long int ans=1;
    int n=b;
    while(n)
    {
        if(n%2==1)
        {
            ans=(ans*tmp)%mod;
            n-=1;
        }
        else
        {
            tmp=(tmp*tmp)%mod;
            n/=2;
        }
    }
    return ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        long long int a,b,c;
        scanf("%lld%lld%lld",&a,&b,&c);
        long long int output=kuaisumi(a,kuaisumi(b,c,mod-1),mod);//这里mod-1就能AC了~
        printf("%lld\n",output);
    }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值