杭电 1498 50 years, 50 colors【二分匹配+最小点覆盖问题】

50 years, 50 colors

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2105    Accepted Submission(s): 1174


Problem Description
On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.


 

Input
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
 

Output
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".
Sample Input
1 1
1
2 1
1 1
1 2
2 1
1 2
2 2
5 4
1 2 3 4 5
2 3 4 5 1
3 4 5 1 2
4 5 1 2 3
5 1 2 3 4
3 3
50 50 50
50 50 50
50 50 50
0 0
 


Sample Output
-1
1
2
1 2 3 4 5
-1
 
 

Author
8600


题目大意:给出n*n的图,给你k次操作,要么横着覆盖,要么纵向覆盖,对于每一个颜色都要讨论,问覆盖上所有的颜色块的时候用的最少点。

典型的最小点覆盖问题,最小点覆盖==最大二分匹配数、行列匹配即可~

#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
int match[105*105];
int vis[105*105];
int color[105];
int map[105][105][105];
vector<int >g[105];
int ans[1055];
int n,k;
void init()
{
    memset(color,0,sizeof(color));
    memset(map,0,sizeof(map));
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            int t;
            scanf("%d",&t);
            map[t][i][j]=1;
            color[t]=1;
        }
    }
}
int find(int x)
{
    for(int i=0;i<g[x].size();i++)
    {
        int u=g[x][i];
        if(vis[u]==0)
        {
            vis[u]=1;
            if(match[u]==-1||find(match[u]))
            {
                match[u]=x;
                return 1;
            }
        }
    }
    return 0;
}
int solve()
{
    int cont=0;
    memset(match, -1, sizeof(match));
    for(int i=1;i<=n;i++)
    {
        memset(vis,0,sizeof(vis));
        if(find(i)!=0)cont++;
    }
    return cont;
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        if(n==0&&k==0)break;
        init();
        int top=0;
        for(int i=1;i<=50;i++)
        {
            if(color[i]!=0)
            {
                for(int l=0;l<=n;l++)
                {
                    g[l].clear();
                }
                for(int j=1;j<=n;j++)
                {
                    for(int k=1;k<=n;k++)
                    {
                        if(map[i][j][k])g[j].push_back(k);
                    }
                }
                if(solve()>k)ans[top++]=i;
            }
        }
        if(top==0)printf("-1\n");
        else
        {
            for(int i=0;i<top-1;i++)
            printf("%d ",ans[i]);
            printf("%d\n",ans[top-1]);
        }
    }
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值