【杭电1498】50years,50colors二分最大匹配--最小点覆盖

二分图
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons". 

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons. 

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times. 


Input

There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0. 

Output

For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1". 

Sample Input

1 1
1
2 1
1 1
1 2
2 1
1 2
2 2
5 4
1 2 3 4 5
2 3 4 5 1
3 4 5 1 2
4 5 1 2 3
5 1 2 3 4
3 3
50 50 50
50 50 50
50 50 50
0 0

Sample Output

-1
1
2
1 2 3 4 5

-1

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,k,a[110],b[110];
int s[110];
int map[110][110];//记录气球颜色
int cout[110];//记录气球出现次数 
int find(int x,int y)//行 颜色 
{
for(int i=1;i<=n;i++)
  {
    if(map[x][i]==y&&b[i]==0)//如果这一列有颜色相同的,且没被覆盖过
    {
    b[i]=1;//此次覆盖 
    if(a[i]==0||find(a[i],y))//这列没有这个颜色或这列其他行有这个颜色 
    {
        a[i]=x;
        return 1;
     } 
    }    
  }
  return 0;
} 
int f(int x)//完全消除该气球所需要的次数
{
    memset(a,0,sizeof(a));//消除每种颜色前清零 
    int sum=0;
    for(int i=1;i<=n;i++)
    {
        memset(b,0,sizeof(b));
        if(find(i,x))
        sum++;
    }
    return sum;
 } 
int main()
{

    while(~scanf("%d%d",&n,&k),(n!=0||k!=0))
    {
        memset(map,0,sizeof(map)); 
        memset(cout,0,sizeof(cout));
        memset(s,0,sizeof(s));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&map[i][j]);
                cout[map[i][j]]++;//统计出现次数
            }
        }
        int t=0; 
        for(int i=1;i<=50;i++)
        {
            if(cout[i]&&f(i)>k)//该颜色气球出现过且不能再K次内完全消除 
            s[t++]=i;//记录符合条件的气球 
         } 
         if(t==0)
         printf("-1\n");
         else
         {
             for(int i=0;i<t-1;i++)
             printf("%d ",s[i]);
             printf("%d\n",s[t-1]);
         }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值