POJ 1988 Cube Stacking【带权并查集】

Cube Stacking
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 22751 Accepted: 7943
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

Source


题目大意:开始每个栈里边都有一个方块,有两种操作,第一个操作M X Y表示把包含X方块的栈里边的所有方块都放在Y方块的栈上边。第二个操作C X询问X方块下边有多少方块。


解释样例:

初始:

1 2 3 4 5 6

M 1 6之后,1放在了6上边,

M 2 4之后,2放在了4上边,现在的栈的状况是这样的:

0 0 0 2 0 1

0 0 3 4 0 6

M 2 6之后 在6号栈里边的情况是: 2 4 1 6

所以C 4=2



以下思路伴随样例行进、



思路:带权并查集,我们在并查集操作的同时赋予节点与节点之间的权值,方块与直接相连的方块边权值我们设定为1。对于这个题我们可以这样构建思路:


我们设定位子在下边的方块为祖宗节点。那么我们设定sum【x】表示x到x的祖宗节点的距离,这样我们在输出的时候,直接输出sum【x】即可。

重点和难点还是放在合并操作上,我们不容易确定两个要连接的节点之间间隔了多少方块,但是我们可以这样考虑:

假设在样例中操作M 2 6的时候,我们找到2的祖宗节点4,找到6的祖宗节点6,如果我们知道6所在集合元素的总个数,那么我们就能确定了4到6的距离。所以我们需要一个数组J【】来存储元素的个数,J【x】表示以x为祖宗节点的集合里边一共有多少元素。这样我们就确定了4下边一共有多少方块,至于2下边有多少方块,我们可以再动态更新。

具体代码实现:

#include<stdio.h>
#include<string.h>
using namespace std;
int f[300005];
int j[300005];//j【x】表示以x为祖宗节点的集合里边一共有多少元素
int sum[3000005];//sum【x】表示x到x的祖宗的边权值
int find(int x)//另外一个作用就是动态更新sum数组
{
    if(x!=f[x])
    {
        int pre=f[x];//pre是x的一个父节点。
        f[x]=find(f[x]);//递归找祖先。
        sum[x]+=sum[pre];
    }
    return f[x];
}
void init()//初始化
{
    for(int i=1;i<=30050;i++)
    {
        f[i]=i;
        j[i]=1;
        sum[i]=0;
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    init();
    while(t--)
    {
        char s[5];
        scanf("%s",s);
        if(s[0]=='M')
        {
            int x,y;
            scanf("%d%d",&x,&y);
            int xx=find(x);
            int yy=find(y);
            if(xx!=yy)
            {
                f[xx]=yy;//规定yy为父节点
                sum[xx]=j[yy];//xx的下边一共有j【yy】个元素
                j[yy]+=j[xx];//对yy的集合元素个数的更新
            }
        }
        if(s[0]=='C')
        {
            int x;
            scanf("%d",&x);
            find(x);
            printf("%d\n",sum[x]);
        }
    }
}







  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值