esus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
Sample Input
2
2
20 25
40
1
8
Sample Output
08:00:40 am
08:00:08 am
题目要找卖n张票的最短时间,用dp的思想,可以把它转化为到第i张票的最短时间,在卖第i张票的时候,有两种策略:
1.单独卖第i张票 2.和第i-1张同时买 于是就有状态转移方程:dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i-1]);
可结合代码理解:
#include <iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
using namespace std;
int main()
{
int n,i,j,k;
long long dp[2005];
long long a[2005];
long long b[2005];
int t;
cin>>t;
while(t--)
{
cin>>n;
for(i=1;i<=n;i++)
cin>>a[i];
for(i=1;i<=n-1;i++)
cin>>b[i];
memset(dp,0,sizeof(dp));
dp[1]=a[1];
for(i=2;i<=n;i++)
dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i-1]);//状态转换
int x=(dp[n]/3600)+8;
int y=(dp[n]/60)%60;
int z=dp[n]%60;
if(x>12)
{
x%=12;
printf("%02d:%02d:%02d pm\n",x,y,z);//格式控制
}
else
printf("%02d:%02d:%02d am\n",x,y,z);
}
return 0;
}