hdu4473 Exam

44 篇文章 0 订阅
Exam
Time Limit:10000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Rikka is a high school girl suffering seriously from Chūnibyō (the age of fourteen would either act like a know-it-all adult, or thinks they have special powers no one else has. You might google it for detailed explanation) who, unfortunately, performs badly at math courses. After scoring so poorly on her maths test, she is faced with the situation that her club would be disband if her scores keeps low.
Believe it or not, in the next exam she faces a hard problem described as follows.
Let’s denote f(x) number of ordered pairs satisfying (a * b)|x (that is, x mod (a * b) = 0) where a and b are positive integers. Given a positive integer n, Rikka is required to solve for f(1) + f(2) + . . . + f(n).
According to story development we know that Rikka scores slightly higher than average, meaning she must have solved this problem. So, how does she manage to do so?
 

Input

There are several test cases.
For each test case, there is a single line containing only one integer n (1 ≤ n ≤ 10 11).
Input is terminated by EOF.
 

Output

For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is the desired answer.
 

Sample Input

     
     
1 3 6 10 15 21 28
 

Sample Output

     
     
Case 1: 1 Case 2: 7 Case 3: 25 Case 4: 53 Case 5: 95 Case 6: 161 Case 7: 246
我们可以发现,从1到n加起来,不就刚好把1-n全取到了么?这样就可以转化为a*b*c的组数,这样不就so easy了!
但还有点小细节看程序
#include <iostream>
#include <math.h>
#include <stdio.h>
using namespace std;
__int64 mypow(__int64  x,__int64 a)//x的a次方根
{
    __int64 m=pow(x,1.0/a),i,j,sum;//先用系统函数把大概范围求出来!
    while(1)
    {
        sum=1;
        for(j=0;j<a;j++)
        {
            sum*=m;
        }
        if(sum<=x)
        {
            m++;
        }
        else
        {
            break;
        }
    }
    while(1)
    {
        sum=1;
        for(j=0;j<a;j++)
        {
            sum*=m;
        }
        if(sum>x)//这没有=号
        {
            m--;
        }
        else
        {
            return m;
        }
    }
}
int main()
{
   __int64 n,i,j,k,sum,iall,jall,ni;
   int tcase=1;
   while(scanf("%I64d",&n)!=EOF)
   {

        iall=mypow(n,3);
        jall=mypow(n,2);
        sum=iall;//iii这种形式的刚好是iall个
        for(i=1;i<=iall;i++)
        {
            ni=n/i;//加快速度
            k=mypow(ni,2);
            sum+=(ni/i+k-2*i)*3;//iij的个数为ni/i-i;ijj这种形式的个数为k-i个
            for(j=i+1;j<=k;j++)//可以推出j小于根号下(n/i)这样速度更快
            {
                sum+=(ni/j-j)*6;
            }

        }

    printf("Case %d: %I64d\n",tcase++,sum);
   }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值