Time Limit: 1000MS | Memory Limit: 65536KB | 64bit IO Format: %lld & %llu |
Description
Farmer John has decided to reward his cows for their hard work by taking them on a tour of the big city! The cows must decide how best to spend their free time.
Fortunately, they have a detailed city map showing the L (2 ≤ L ≤ 1000) major landmarks (conveniently numbered 1..L) and the P (2 ≤ P ≤ 5000) unidirectional cow paths that join them. Farmer John will drive the cows to a starting landmark of their choice, from which they will walk along the cow paths to a series of other landmarks, ending back at their starting landmark where Farmer John will pick them up and take them back to the farm. Because space in the city is at a premium, the cow paths are very narrow and so travel along each cow path is only allowed in one fixed direction.
While the cows may spend as much time as they like in the city, they do tend to get bored easily. Visiting each new landmark is fun, but walking between them takes time. The cows know the exact fun valuesFi (1 ≤ Fi ≤ 1000) for each landmark i.
The cows also know about the cowpaths. Cowpath i connects landmark L1i to L2i (in the directionL1i -> L2i ) and requires timeTi (1 ≤ Ti ≤ 1000) to traverse.
In order to have the best possible day off, the cows want to maximize the average fun value per unit time of their trip. Of course, the landmarks are only fun the first time they are visited; the cows may pass through the landmark more than once, but they do not perceive its fun value again. Furthermore, Farmer John is making the cows visit at least two landmarks, so that they get some exercise during their day off.
Help the cows find the maximum fun value per unit time that they can achieve.
Input
* Line 1: Two space-separated integers: L and P
* Lines 2..L+1: Line i+1 contains a single one integer: Fi
* Lines L+2..L+P+1: Line L+i+1 describes cow pathi with three space-separated integers: L1i ,L2i , and Ti
Output
* Line 1: A single number given to two decimal places (do not perform explicit rounding), the maximum possible average fun per unit time, or 0 if the cows cannot plan any trip at all in accordance with the above rules.
Sample Input
5 7 30 10 10 5 10 1 2 3 2 3 2 3 4 5 3 5 2 4 5 5 5 1 3 5 2 2
5 2 2
Sample Output
6.00
题意:给出n, m和点权和边权,要求一个回路,使点权和与边权和的比值最大
解法:
设答案为ans,则 (点权) happy[v] / dis[i][j] = ans
移项得:ans*dis[u][v] - happy[v] = 0
那么如果二分我们的ans, 如何判断合法?
考虑把每条边的边权设为 ans*dis[u][v]-happy[v],
那么, 如果有负权环,这个环首先肯定是一个回路。
第二,说明: ans*dis[u][v] - happy[v] < 0 -> ans*dis[u][v] < happy[v] -> ans < happy[v]/dis[u][v]
所以 ans 是合法解并且可以再大
否则不合法
负权环用SPFA做
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define MAXN (1000+5)
#define INF 0x3f3f3f3f
#define pb push_back
#define Set(a, v) memset(a, v, sizeof(a))
#define For(i, a, b) for(int i = (a); i <= (int)(b); i++)
struct node{
int v, dis;
};
vector<node> G[MAXN];
int n, happy[MAXN], cnt[MAXN];
bool inq[MAXN];
double d[MAXN];
bool spfa(double base){
queue<int> q;
For(i, 1, n) d[i] = 1.0*INF;
Set(cnt, 0); Set(inq, 0);
d[1] = 0.0;
q.push(1); inq[1] = true;
while(!q.empty()){
int now = q.front(); q.pop();
inq[now] = false;
For(i, 0, G[now].size()-1){
int v = G[now][i].v;
double nd = base*G[now][i].dis - 1.0*happy[v];
if(d[v] > (d[now]+nd)){
d[v] = d[now]+nd;
if(!inq[v]){
inq[v] = true;
if(++cnt[v] > n) return true;
q.push(v);
}
}
}
}
return false;
}
int main(){
int m, S = 0;
scanf("%d%d", &n, &m);
For(i, 1, n) scanf("%d", &happy[i]), S += happy[i];
For(i, 1, m){
int u, v, w;
scanf("%d%d%d", &u, &v, &w);
G[u].pb((node){v, w});
}
double L = 0.0, R = 1.0*S, ans;
while((R-L) > 1e-3){
double mid = (L+R) / 2;
if(spfa(mid)){
ans = mid;
L = mid;
}else R = mid;
}
printf("%.2f\n", ans);
return 0;
}