hdu 1232 畅通工程(并查集)

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1232

畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51836    Accepted Submission(s): 27642


Problem Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
 

Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。
 

Sample Input
  
  
4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0
 

Sample Output
 
 
1 0 2 998

思路:只要判断有多少个联通分量就可以了,然后减一

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
#include<vector>
#include<queue>
#include<iostream>
#include<cstdio>
using namespace std;
const int maxn = 1000 + 10;
int father[maxn];
void makeSet(int n){
    for(int i=0;i<=n;i++) father[i] = i; //初始化,自己的父节点是自己
}
int Find(int x){ //Find 查找当前集合的根节点
    if(x == father[x]) return x;
    return father[x] = Find(father[x]); //路径压缩
}
void Union(int x,int y){ //合并集合
    int xroot = Find(x);
    int yroot = Find(y);
    if(xroot != yroot){
        father[xroot] = yroot;//将x接到y的下面就是x的根节点是y;
    }
}
int Find2(int x){//迭代版本
    int tempRoot;
    int root = x;
    while(root != father[root]) //找到根节点。
        root = father[root];
    while(x != root){
        tempRoot = father[x]; //x的父节点用临时变量存一下。
        father[x] = root; //x的父节点设置成根 (x 压缩到根节点了)
        x = tempRoot;   //x 赋值为 x的父节点(之前存过的);
    }
    return root; // 最后返回根节点
}
int main(){
    int n,m;
    while(scanf("%d",&n)!=EOF && n){
        scanf("%d",&m);
        makeSet(n);
        int ans = 0;
        int a,b;
        for(int i=0;i<m;i++){
            scanf("%d%d",&a,&b);
            Union(a,b);
        }
        for(int i=1;i<=n;i++){
            if(father[i] == i) ans++;
        }
        printf("%d\n",ans-1);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值