迷宫问题——bfs

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
#include<stdio.h> 
#include<queue>
#include<stack> 
#include<algorithm>
using namespace std;
int maze[5][5]={0};
int d[5][5]={0};
int dx[4]={0,1,0,-1},dy[4]={1,0,-1,0};
typedef pair<int,int> P;
P sum[50];
int main()
{
    for(int i=0;i<5;i++){
    	for(int j=0;j<5;j++){
    		scanf("%d",&maze[i][j]);
		}
	}
	d[0][0]=0;
	queue<P> que;
	que.push(P(0,0));
	printf("(0, 0)\n");
	while(que.size()){
		P p=que.front();
		que.pop();
		if(p.first==4&&p.second==4) break;
		for(int i=0;i<4;i++){
			int nx=p.first+dx[i],ny=p.second+dy[i];
			if(nx>=0&&nx<5&&ny>=0&&ny<5&&maze[nx][ny]==0&&d[nx][ny]==0){
				d[nx][ny]=d[p.first][p.second]+1;
				que.push(P(nx,ny));
			}
		}
	}
	queue<P> que2;
	stack<P> sta;
	que2.push(P(4,4));
	sta.push(P(4,4));
	while(que2.size()){
		P p1=que2.front();
		que2.pop();
		if(p1.first==1&&p1.second==0) break;
		for(int i=3;i>=0;i--){
			int mx=p1.first+dx[i],my=p1.second+dy[i];
			if(mx>=0&&mx<5&&my>=0&&my<5&&d[mx][my]==d[p1.first][p1.second]-1){
				que2.push(P(mx,my));
				sta.push(P(mx,my));
			}
		}
	}
	while(!sta.empty()){
		P p2=sta.top();
		sta.pop();
		printf("(%d, %d)\n",p2.first,p2.second);
	}
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值