1023 Have Fun with Numbers (20)(20 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899
Sample Output:

Yes
2469135798


题目大意是要判断给定的一个数在乘2后,数字的组成和之前是否一致。因为数字很大,不能直接存储,需要借助字符串模拟乘2的步骤。

#include <iostream>
#include <cstdio>
#include <string>
#include <stack>

using namespace std;
int book[10];
int main(int argc, char const *argv[])
{
    string s,ans;
    cin>>s;
    int next = 0;
    stack<int>q;
    for (int i = s.length()-1; i >= 0; --i)
    {
        int digit = s[i]-'0';
        book[digit]++;
        int num = digit*2;
        num += next;
        int cur = num%10;
        next = 0;
        if(num >= 10)
        {
            next = num/10;
        }
        q.push(cur);
        book[cur]--;
    }
    if(next)
    {
        book[next]--;
        q.push(next);
    }
    int flag = 0;
    for (int i = 0; i < 10; ++i)
    {
        if(book[i] != 0)
        {
            flag = 1;
            break;
        }
    }
    if(flag)
        cout<<"No"<<endl;
    else
        cout<<"Yes"<<endl;
    while(!q.empty())
    {
        cout<<q.top();
        q.pop();
    }
    cout<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值