HDU - 4497 GCD and LCM 数论

Given two positive integers G and L, could you tell me how many solutions of (x, y, z) there are, satisfying that gcd(x, y, z) = G and lcm(x, y, z) = L? 
Note, gcd(x, y, z) means the greatest common divisor of x, y and z, while lcm(x, y, z) means the least common multiple of x, y and z. 
Note 2, (1, 2, 3) and (1, 3, 2) are two different solutions.

Input

First line comes an integer T (T <= 12), telling the number of test cases. 
The next T lines, each contains two positive 32-bit signed integers, G and L. 
It’s guaranteed that each answer will fit in a 32-bit signed integer.

Output

For each test case, print one line with the number of solutions satisfying the conditions above.

Sample Input

2 
6 72 
7 33 

Sample Output

72 
0

题解:

#include<cstdio>
using namespace std;
typedef long long ll;
ll g,l;
ll prime[101000],len;
bool ok[100100];
void init()
{
	for(int i=2;i<=1e5;i++)
	{
		if(!ok[i]) prime[len++]=i;
		for(int j=0;j<len&&i*prime[j]<=1e5;j++)
		{
			ok[i*prime[j]]=1;
			if(i%prime[j]==0) break;
		}
	}
}
int main(){
	int T;
	scanf("%d",&T);
	init();
	while(T--)
	{
		scanf("%lld%lld",&g,&l);
		if(l%g!=0)
		{
			printf("0\n");
			continue;
		}
		g=l/g;
		ll ans=1;
		for(int i=0;i<len&&prime[i]*prime[i]<=g;i++)
		{
			if(g%prime[i]==0)
			{
				int cnt=0;
				while(g%prime[i]==0)
				{
					cnt++;
					g/=prime[i];
				}
				ans*=6*(cnt);
			}
		}
		if(g!=1) ans*=6;
		printf("%lld\n",ans);
	}
	return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值