Out of Hay
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 16812 | Accepted: 6570 |
Description
The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1.
Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry.
Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.
Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry.
Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.
Input
* Line 1: Two space-separated integers, N and M.
* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.
* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.
Output
* Line 1: A single integer that is the length of the longest road required to be traversed.
Sample Input
3 3 1 2 23 2 3 1000 1 3 43
Sample Output
43
Hint
OUTPUT DETAILS:
In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.
In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.
Source
题意:由于牛丢了,Bessie打算去各个农场调查情况,起初Bessie在农场1,Bessie在路上会带上足够的水(水量和路的长度成正比,且比值为1)并且每个农场都有足够量的
水,那么请问在总路程最短的情况下他所需要带的最多的水量是多少?(水量以盎司为单位)
解题思路:最小生成树,Prim和Kruskal都可以.。写这题真的是被memset坑了
#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f3f
#include<iostream>
using namespace std;
int lowcost[2010];
int mp[2010][2010];
int visit[2010];
int n,ans;
void prime()
{
int mn,i,j,next,mincost=0;
memset(visit,0,sizeof(visit));
for(i=1; i<=n; i++)
{
lowcost[i]=mp[1][i];
//printf("low:%d\n",lowcost[i]);
}
visit[1]=1;
for(i=1; i<n; i++)
{
mn=INF;
for(j=1; j<=n; j++)
{
if(!visit[j]&&mn>lowcost[j])
{
mn=lowcost[j];
next=j;
}
}
if(mn==INF)
return ;
ans=max(mn,ans);
mincost+=mn;
//printf("minc:%d\n",mincost);
visit[next]=1;
for(j=1; j<=n; j++)
{
if(!visit[j]&&lowcost[j]>mp[next][j])
{
lowcost[j]=mp[next][j];
}
}
}
printf("%d\n",ans);
}
int main()
{
int m;
int a,b,c;
while(~scanf("%d%d",&n,&m))
{
//memset(mp,INF,sizeof(mp));//这个地方要注意,这样给mp数组赋值是不对的,可以用for循环或者fill都是可以的
//memset函数只能给数组赋值为0或-1.
/*for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
mp[i][j]=INF;*/
for(int i=1;i<=n;i++)
fill(mp[i],mp[i]+n+1,INF);//fill只能对一维的数组进行赋值
ans=0;
for(int i=1; i<=m; i++)
{
scanf("%d%d%d",&a,&b,&c);
if(c<mp[a][b])//判断重边,这步不能少
mp[a][b]=mp[b][a]=c;
}
prime();
}
return 0;
}
Kruskal解法:
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAXN =2100;
const int MAXM =40040;
struct EdgeNode
{
int from;
int to;
int w;
}Edges[MAXM];
int father[MAXN];
int find(int x)
{
if(x != father[x])
father[x] = find(father[x]);
return father[x];
}
int cmp(EdgeNode a,EdgeNode b)
{
return a.w < b.w;
}
void Kruskal(int n,int m)
{
sort(Edges,Edges+m,cmp);
int Count = 0, maxx = 0;
for(int i = 0; i < m; ++i)
{
int u = find(Edges[i].from);
int v = find(Edges[i].to);
if(u!=v)
{
father[v] = u;
Count++;
if(maxx < Edges[i].w)
maxx = Edges[i].w;
if(Count == n-1)
break;
}
}
printf("%d\n",maxx);
}
int main(){
int n,m;
while(~scanf("%d%d",&n,&m)){
for(int i=0;i<n;i++)
father[i]=i;
for(int i=0;i<m;i++){
scanf("%d%d%d",&Edges[i].from,&Edges[i].to,&Edges[i].w);
}
Kruskal(n,m);
}
}