POJ3927 Priest John's Busiest Day

Priest John's Busiest Day
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 533 Accepted: 171

Description

John is the only priest in his town. October 26th is the John's busiest day in a year because there is an old legend in the town that the couple who get married on that day will be forever blessed by the God of Love. This year N couples plan to get married on the blessed day. The i-th couple plan to hold their wedding from time Si to time Ti. According to the traditions in the town, there must be a special ceremony on which the couple stand before the priest and accept blessings. Moreover, this ceremony must be longer than half of the wedding time and can't be interrupted. Could you tell John how to arrange his schedule so that he can hold all special ceremonies of all weddings? 

Please note that: 
John can not hold two ceremonies at the same time. 
John can only join or leave the weddings at integral time. 
John can show up at another ceremony immediately after he finishes the previous one.

Input

The input consists of several test cases and ends with a line containing a zero. 
In each test case, the first line contains a integer N ( 1 ≤ N ≤ 100,000) indicating the total number of the weddings. 
In the next N lines, each line contains two integers Si and Ti. (0 <= Si < Ti <= 2147483647)

Output

For each test, if John can hold all special ceremonies, print "YES"; otherwise, print “NO”.

Sample Input

3 
1 5 
2 4 
3 6 
2 
1 5 
4 6 
0

Sample Output

NO
YES

Source


贪心,记录每场ceremony必经的时间点,并按其排序,如果没有冲突,那么方案可行,接下来的操作就是普通的任务安排了。。。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
struct mony{
	int s,t;
	int ts,tt;
	int last;
	friend bool operator <(mony a,mony b){
		if(a.ts != b.ts)
			return a.ts < b.ts;
		return a.tt < b.tt;
	}
};
int n;
vector<mony>mm;
void init(){
	mm.clear();
	mony tk;
	for(int i = 0; i < n; i++){
		int a,b;
		scanf("%d%d",&a,&b);
		tk.s = a;
		tk.t = b;
		tk.last = (b-a)/2+1;
		if((b-a)%2==0){
			tk.ts = (b-a)/2+a-1;
			tk.tt = tk.ts+2;
		}else{
			tk.ts = (b-a-1)/2+a;
			tk.tt = tk.ts+1;
		}
		mm.push_back(tk);
	}
	sort(mm.begin(),mm.end());
}
void solve(){
	bool flag = 1;
	int now_s,now_t,last_t=mm[0].s+mm[0].last;
	for(int i = 1; i < n; i++){
		now_s = max(mm[i].s,last_t);
		if(mm[i].t-now_s < mm[i].last){
			flag = 0;
			break;
		}
		last_t = min(now_s+mm[i].last,mm[i].t);
	}
	if(flag) cout<<"YES"<<endl;
	else cout<<"NO"<<endl;	
}
int main(){
	while(~scanf("%d",&n)&&n){
		init();
		solve();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值