B-number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2168 Accepted Submission(s): 1165
Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
Output
Print each answer in a single line.
Sample Input
13 100 200 1000
Sample Output
1 1 2 2
简单的数位DP,一开始一个小地方写错了,卡了好久。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
int n;
vector<int>digit;
int dp[12][10][13];
int dfs(int pos,int statu,int reminder,int done){
if(pos==-1) return statu==2&&reminder==0;
if(!done && ~dp[pos][statu][reminder]) return dp[pos][statu][reminder];
int end = done? digit[pos]:9;
int res = 0;
for(int i = 0; i <= end; i++){
int tsta = statu;
int re = (reminder*10+i)%13;
if(statu == 0&&i == 1)
tsta = 1;
if(statu == 1&&i==3)
tsta = 2;
if(statu == 1 && i != 1 && i != 3)
tsta = 0;
res += dfs(pos-1,tsta,re,done&&i==end);
}
if(!done) dp[pos][statu][reminder] = res;
return res;
}
int solve(int num){
digit.clear();
while(num){
digit.push_back(num%10);
num /= 10;
}
memset(dp,-1,sizeof dp);
return dfs(digit.size()-1,0,0,1);
}
int main(){
while(cin >> n){
cout<<solve(n)<<endl;
}
return 0;
}