UVa10325 - The Lottery(容斥+最小公倍数)

 The Lottery 

The Sports Association of Bangladesh is in great problem with their latest lottery 'Jodi laiga Jai'. There are so many participants this time that they cannot manage all the numbers. In an urgent meeting they have decided that they will ignore some numbers. But how they will choose those unlucky numbers!! Mr. NondoDulal who is very interested about historic problems proposed a scheme to get free from this problem.

You may be interested to know how he has got this scheme. Recently he has read the Joseph's problem.

The Problem

There are N tickets which are numbered from 1 to N. Mr. Nondo will choose M random numbers and then he will select those numbers which is divisible by at least one of those M numbers. The numbers which are not divisible by any of those M numbers will be considered for the lottery.

As you know each number is divisible by 1. So Mr. Nondo will never select 1 as one of those M numbers. Now given N,M and M random numbers, you have to find out the number of tickets which will be considered for the lottery.

The Input

Each input set starts with two Integers N (10<=N<2^31) and M (1<=M<=15). The next line will contain M positive integers each of which is not greater than N. Input is terminated by EOF.

The Output

Just print in a line out of N tickets how many will be considered for the lottery.

Sample Input

10 2
2 3
20 2
2 4

Sample Output

3
10
 
 
题意:n个数中,有多少个数与m个数互质。
思路:只要先知道这m个数的倍数的个数,然后用总数减去就可以了。至于计算m个数的倍数的个数,用容斥原理解决。‘
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
using namespace std;
typedef long long ll;
ll n,m;
ll num[20];
ll ans;
ll gcd(ll a,ll b){
	if(b==0) return a;
	else return gcd(b,a%b);
}
ll lcm(ll a,ll b){
	return a/gcd(a,b)*b;
}
vector<ll> vn;
int main(){
	while(cin >> n >> m){
		ans = 0;
		for(int i = 0; i < m; i++) cin >> num[i];
		for(int i = 1; i < (1<<m); i++){
			vn.clear();
			for(int j = 0; j < m; j++){
				if(i&(1<<j)){
					vn.push_back(num[j]);
				}
			}
			if(vn.size()==1){
				ans += n/vn[0];//cout<<ans<<endl;
				continue;
			}
			ll lc = vn[0];
			for(int i = 1; i < vn.size(); i++){
				lc = lcm(lc,vn[i]); 
			}
			
			if(vn.size()&1){
				ans += n/lc;
			}else{
				ans -= n/lc;
			}
		} 
		cout<<n-ans<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值