POJ 2342

11 篇文章 0 订阅
3 篇文章 0 订阅
Time Limit: 1000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u


Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

Source

Ural State University Internal Contest October'2000 Students Session

题意:
要举行一个party,一个人和他的直属上司不能同时来,每个人都有一个欢乐值,求最大的欢乐值。 转化为树,即父亲与儿子不能同时存在,典型的树状DP。
确定状态:dp[i][0]表示 i结点不来时,i及其子树最大的欢乐值
          dp[i][1]表示 i节点来时,i及其子树最大的欢乐值
状态转移方程:
          x是i的父节点
          dp[x][0] += max(dp[i][0], dp[i][1]);
          dp[x][1] += dp[i][0] ;
          注意初始化 dp[i][0] = 0; dp[i][1] = 1;
          结果: ans = max(dp[root][0], dp[root][1]);
实现:    保存父节点,dfs()实现记忆化搜索

AC代码:
        
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 6000+5
int n,rat[maxn],fa[maxn],dp[maxn][2],vis[maxn];
void dfs(int x )
{
  vis[x] = 1;
  for(int i = 1;i <= n;i ++)
  {
    if(!vis[i] && fa[i] == x)
    {
      dfs(i);
      dp[x][0] += max(dp[i][0], dp[i][1]);
      dp[x][1] += dp[i][0] ;
    }
  }
}
int main()
{
    while(scanf("%d", &n) != EOF)
    {
     int a,b,root;
     memset(vis, 0, sizeof(vis));
     memset(fa, 0, sizeof(fa));
     for(int i = 1;i <= n;i ++)
     scanf("%d", &rat[i]);
     for(int i = 1;i <= n-1;i ++)
     {
       scanf("%d%d", &a, &b);
       fa[a] = b;
     }
     scanf("%d%d", &a, &b);
     for(int i = 1;i <= n;i ++)
     {
       if(fa[i] == 0) root = i;
       dp[i][0] = 0;
       dp[i][1] = rat[i];
     }
     dfs(root);
     printf("%d\n",max(dp[root][0],dp[root][1]));
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值