Connect the Cities

Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

 

Sample Input
  
  
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

 

Sample Output
  
  
1
 

 

Author
dandelion
 

 

Source
 

 

Recommend
lcy
好久没怎么做题目了。竟然这道题目也花了不少时间..........郁闷
其实就是并查集的应用。
要判断边数,达到n-1条时就break,否则最后-1
代码:
/*
* File:   main.cpp
* Author: mtttt
*
* Created on 2010年4月9日, 上午8:59
*/


#include <stdlib.h>
#include <iostream>
#include <algorithm>
using namespace std ;
/*
*
*/

int
n ,m ,k ;
struct
node
{

  int
s ,e ,v ;
}
a [ 25001 ];
int
p [ 501 ],q [ 501 ];
int
cmp ( const void *b , const void *c )
{

    return
(*(node *)b ).v -(*(node *)c ).v ;
}

int
find ( int i )
{

    while
(i !=p [i ]) i =p [i ];
    return
i ;
}

void
solve ()
{

    int
cc ,count = 0 ;
    cin >>n >>m >>k ;
    for
( int i = 1 ;i <=n ;i ++)
        p [i ]=i ;

    for
( int i = 1 ;i <=m ;i ++)
        scanf ( "%d %d %d" ,&a [i ].s ,&a [i ].e ,&a [i ].v );

    qsort (a + 1 ,m , sizeof (a [ 1 ]),cmp );

    for
( int i = 1 ;i <=k ;i ++)
    {

        scanf ( "%d" ,&cc );
         scanf ( "%d" ,&q [ 1 ]);
        for
( int j = 2 ;j <=cc ;j ++)
        {

            scanf ( "%d" ,&q [j ]);
            int
r1 =find (q [j - 1 ]);
            int
r2 =find (q [j ]);
            if
(r1 !=r2 )
            {

                count ++;
                p [r1 ]=r2 ;
            }
        }
    }

    int
cost = 0 ;
    for
( int i = 1 ;i <=m ;i ++)
    {

        if
(count >=n - 1 ) break ;
        int
r1 =find (a [i ].s );
        int
r2 =find (a [i ].e );
        if
(r1 !=r2 )
           {

               count ++;
               p [r1 ]=r2 ;
               cost +=a [i ].v ;
           }
    }

    if
(count ==n - 1 )
    cout <<cost <<endl ;
    else

        cout << "-1" <<endl ;
}

int
main ( int argc , char ** argv ) {
   // freopen("2.in","r",stdin);
    int cas ;
    cin >>cas ;
    while
(cas --)
    {

       // init();
       // input();
        solve ();
    }

    return
(EXIT_SUCCESS );
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值