1013 Battle Over Cities (25分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing Knumbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

 题目大意:

由于在战争期间,一些城市被敌人攻占而无法开放,导致城市间无法连通,因此需要修复道路使其他城市间能够连通。给出城市编号、城市间的道路以及被侵占的城市编号,现要求你求出在某个城市被侵占的情况下,使各个城市间(除被侵占的城市外)能够相互连通需要修复的道路数量。

代码如下:

#include<iostream>
#include<cstdio>
#include<vector>
using namespace std;
//思路:
//1.用并查集统计连通分量 
//2.要求出除被攻占的城市外其他城市是否连通,即求出除被攻占的点外其他点是否在一个连通分量中
//3.vector存储下题目给出的互通路径,后根据给出的被攻占的城市考虑是否连接这条路径(即是否要merge) 
//4.需要修复的高速公路数量 = 连通分量数量 - 2(包括被攻占的城市独立开所占用的连通分量) 


struct Road{
	int a;
	int b;
}; 

int N,M,K;
int father[1010];
vector<Road> roads;  

//寻找根 
int findFather(int x){
	if(father[x] == x)
		return x;
	else
		return father[x];
} 
//合并 
void merge(int x,int y){
	int fa = findFather(x);
	int fb = findFather(y);
	if(fa != fb)
		father[fb] = fa;
}

int main(){
	scanf("%d%d%d",&N,&M,&K);
	for(int i = 1 ; i <= M ; i ++){
		Road r;
		scanf("%d%d",&r.a,&r.b);
		roads.push_back(r);
	}
	for(int i = 1 ; i <= K ; i ++){
		int city;
		scanf("%d",&city);
		for(int z = 1 ; z <= N ; z ++)
			father[z] = z;	
		for(int j = 0 ; j < roads.size() ; j ++){
			if(roads[j].a != city && roads[j].b != city){
				merge(roads[j].a,roads[j].b);
			}
		}
		int sum = 0; //连通分量个数 
		for(int k = 1 ; k <= N ; k++){ 
			if(findFather(k) == k)
				sum ++;
		}
		printf("%d\n",sum-2);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值