Digital Library

1022. Digital Library (30)

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.

Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

本题要求哦我们能够通过书名或者关键词等匹配书籍,难点在于如何读取并存储给定的信息。

我的做法是:

先用getline()函数读取每一行的字符串

对于key word,我们用stream流再次读取该行字符串,通过空格将每一个keyword存储在数组中

头文件<algorithm>:

可以使用sort()函数对vector进行排序,默认为升序
降序则添加greater参数sort(bookID[i].begin(),bookID[i].end(),greater<string>()),需要包含头文件<functional>


#include <iostream>
#include <vector>
#include <queue>
#include <string>
#include <algorithm>
#include <functional>
#include <sstream>

using namespace std;

struct Book {
	vector<vector<string> > label;
	Book() {
		label.resize(6);
	}
};

int main() {
	int n, m;
	cin >> n;
	getchar();//skip the enter after 'n' otherwise the getline() while get the '/n'in the first line with 'n';
	vector<Book> books(n);
	string ID, title, author, wordlist, publisher, year;
	string keyword;
	for (int i = 0;i < n;i++) {
		getline(cin, ID);
		getline(cin, title);
		getline(cin, author);
		getline(cin, wordlist);
		getline(cin, publisher);
		getline(cin, year);
		books[i].label[0].push_back(ID);
		books[i].label[1].push_back(title);
		books[i].label[2].push_back(author);
		istringstream istr(wordlist);
		while (!istr.eof()) {
			istr >> keyword;
			books[i].label[3].push_back(keyword);
		}
		books[i].label[4].push_back(publisher);
		books[i].label[5].push_back(year);

	}
	cin >> m;
	vector<int> label(m);
	vector<string> search(m);
	for (int i = 0;i < m;i++) {
		cin >> label[i];
		getchar();
		getchar();
		getline(cin, search[i]);
	}

	vector<bool> found(m, false);
	vector<vector<string> > bookID(m);
	for (int i = 0;i < m;i++) {
		for (int j = 0;j < n;j++) {
			for (int k = 0;k < books[j].label[label[i]].size();k++) {
				if (search[i] == books[j].label[label[i]][k]) {
					bookID[i].push_back(books[j].label[0][0]);//push the id of the matched book
					found[i] = true;
				}
			}
		}
	}

	for (int i = 0;i < m;i++) {
		cout << label[i] << ": " << search[i] << endl;
		if (found[i]) {
			sort(bookID[i].begin(), bookID[i].end());//sort the book ID ascending
			for (int j = 0; j < bookID[i].size(); j++) {
				cout << bookID[i][j] << endl;
			}
		}
		else
			cout << "Not Found" << endl;
	}
	system("pause");
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
ACM Digital Library(ACM数字图书馆)是全球历史最悠久和最大的计算机教育、科研机构。它收录了美国计算机协会的各种电子期刊、会议录、快报等文献的全文信息,并提供出版物信息。此外,ACM Digital Library还提供了其他3000多家出版机构的计算机文献的文摘索引信息(The Guide)。ACM致力于发展信息技术教育、科研和应用,其出版物和会议记录被全球计算机领域的专业人士视为最具权威和前瞻性的领导者。ACM Digital Library广泛收录了多种ACM电子出版物,包括15年的期刊和杂志、ACM9年的会议记录以及超过25万页的全文资料。此外,你可以在The Guide to Computing Literature中查找计算机领域重要文献的书目信息。\[2\]\[3\] #### 引用[.reference_title] - *1* [如何免费下载ACM数字图书馆文献](https://blog.csdn.net/weixin_46136127/article/details/113838644)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^koosearch_v1,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* [ACM Digital Library访问及完整联动Zotero](https://blog.csdn.net/weixin_45884316/article/details/127511739)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^koosearch_v1,239^v3^insert_chatgpt"}} ] [.reference_item] - *3* [ACM数据库的检索应用](https://blog.csdn.net/smart819819/article/details/8201844)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^koosearch_v1,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值