Have Fun with Numbers

1023. Have Fun with Numbers (20)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798

本题的主要考点是大数字的乘法。

因为输入可能有20位,即使用long long int也不够存储。

计算出输入的两倍之后,通过计算0-9的个数就能判断出结果。

#include <iostream>
#include <vector>
#include <string>
#include <algorithm>
using namespace std;

int main() {
	string number;
	cin >> number;
	vector<int> digit(10, 0);
	string result;
	int index, flag = 0;
	char chr;
	for (int i = number.length()-1; i >=0; i--) {
		//count the digit
		index = number[i] - '0';
		digit[index]++;
		//double the number
		index = index * 2 + flag;
		flag = index / 10;
		index = index % 10;
		chr = index + '0';
		result.push_back(chr);
	}
	if (flag != 0) {
		chr = flag + '0';
		result.push_back(chr);
	}
	reverse(result.begin(), result.end());

	for (int i = 0; i < result.length(); i++) {
		index = result[i] - '0';
		digit[index]--;
	}

	bool yes = true;
	for (int i = 0; i < 10; i++) {
		if (digit[i] != 0) {
			yes = false;
			break;
		}

	}
	if (number.length() != result.length())
		yes = false;
	if (yes)
		cout << "Yes" << endl;
	else
		cout << "No" << endl;
	cout << result;
	system("pause");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值