TOJ 1082.Ride to School

题目链接:http://acm.tju.edu.cn/toj/showp1082.html


1082.    Ride to School
Time Limit: 1.0 Seconds    Memory Limit: 65536K
Total Runs: 823    Accepted Runs: 402



Many graduate students of Peking University are living in Wanliu Campus, which is 4.5 kilometers from the main campus - Yanyuan. Students in Wanliu have to either take a bus or ride a bike to go to school. Due to the bad traffic in Beijing, many students choose to ride a bike.

We may assume that all the students except "Charley" ride from Wanliu to Yanyuan at a fixed speed. Charley is a student with a different riding habit - he always tries to follow another rider to avoid riding alone. When Charley gets to the gate of Wanliu, he will look for someone who is setting off to Yanyuan. If he finds someone, he will follow that rider, or if not, he will wait for someone to follow. On the way from Wanliu to Yanyuan, at any time if a faster student surpassed Charley, he will leave the rider he is following and speed up to follow the faster one.

We assume the time that Charley gets to the gate of Wanliu is zero. Given the set off time and speed of the other students, your task is to give the time when Charley arrives at Yanyuan.

Input

There are several test cases. The first line of each case is N (1 ≤ N ≤ 10000) representing the number of riders (excluding Charley). N = 0 ends the input. The following N lines are information of N different riders, in such format:

Vi [TAB] Ti

Vi is a positive integer ≤ 40, indicating the speed of the i-th rider (kph, kilometers per hour). Ti is the set off time of the i-th rider, which is an integer and counted in seconds. In any case it is assured that there always exists a nonnegative Ti.

Output

Output one line for each case: the arrival time of Charley. Round up (ceiling) the value when dealing with a fraction.

Sample Input

4
20	0
25	-155
27	190
30	240
2
21	0
22	34
0

Sample Output

780
771


Source: China 2004 - Beijing Preliminary
Submit   List    Runs   Forum   Statistics

这个题需要一点技巧,本来想的特别复杂,然后一直写不出来。。拜读学习一波才知道:不管在过程中跟着谁,最终都只会与最快的那个一同到达,所以只需要求所有人的最小值即可,还需要注意的是:时间为负的不需考虑,因为如果他很快,那么你永远都赶不上,如果速度不算太快,你赶上了,也没什么用,因为你会跟着更快的。


#include <stdio.h>
#include <algorithm>
#define inf 1000000000
int main(){
	int cast;
	double v,t,min;
	while(scanf("%d",&cast) && cast){
		min=inf;
		for(int i=0;i<cast;i++){
			scanf("%lf%lf",&v,&t);
			if(t<0) continue;
			double tmp=t+16200.0/v;
			if(tmp<min)
				min=tmp;
		}
		if((int)min<min) min++;
		printf("%d\n",(int)min);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值