TOJ 2896.Antimonotonicity(贪心)

题目链接:http://acm.tju.edu.cn/toj/showp2896.html


2896.    Antimonotonicity
Time Limit: 4.0 Seconds    Memory Limit: 65536K
Total Runs: 419    Accepted Runs: 177



I have a sequence Fred of length n comprised of integers between 1 and n inclusive. The elements of Fred are pairwise distinct. I want to find a subsequence Mary of Fred that is as long as possible and has the property that: 
   Mary[0] > Mary[1] < Mary[2] > Mary[3] < ...

Input

The first line of input will contain a single integer T expressed in decimal with no leading zeroes. T will be at most 50. T test cases will follow. 
Each test case is contained on a single line. A line describing a test case is formatted as follows: 

   n Fred[0] Fred[1] Fred[2] ... Fred[n-1].
where n and each element of Fred is an integer expressed in decimal with no leading zeroes. No line will have leading or trailing whitespace, and two adjacent integers on the same line will be separated by a single space. n will be at most 30000. 

Output

For each test case, output a single integer followed by a newline --- the length of the longest subsequence Mary of Fred with the desired properties. 

Sample Input

4
5 1 2 3 4 5
5 5 4 3 2 1
5 5 1 4 2 3
5 2 4 1 3 5

Sample Output

1
2
5
3

Tor Myklebust


Source: Waterloo Local Contest Jul. 14, 2007
Submit   List    Runs   Forum   Statistics


贪心,

#include <stdio.h>
#define Max 30001
int a[Max],cast,n,count;
int main(){
	scanf("%d",&cast);
	while(cast--){
		scanf("%d",&n);
		for(int i=0;i<n;i++)
			scanf("%d",&a[i]);
		count=1;
		for(int i=0;i<n-1;i++){
			if(a[i]>a[i+1]){
				++count;
				int s=0;
				for(int j=i+1;j<n-1;j++)
					if((s==0&&a[j]<a[j+1])||(s==1&&a[j]>a[j+1])){
						++count;
						s^=1;
					}
				break;
			}
		}
		printf("%d\n",count);
	}
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值