HDU 2818 Building Block, poj 1988 Cube Stacking(带权并查集)

链接:

HDU: http://acm.hdu.edu.cn/showproblem.php?pid=2818

POJ:  http://poj.org/problem?id=1988


题目:

Problem Description
John are playing with blocks. There are N blocks (1 <= N <= 30000) numbered 1...N。Initially, there are N piles, and each pile contains one block. Then John do some operations P times (1 <= P <= 1000000). There are two kinds of operation:

M X Y : Put the whole pile containing block X up to the pile containing Y. If X and Y are in the same pile, just ignore this command. 
C X : Count the number of blocks under block X 

You are request to find out the output for each C operation.
 

Input
The first line contains integer P. Then P lines follow, each of which contain an operation describe above.
 

Output
Output the count for each C operations in one line.
 

Sample Input
  
  
6 M 1 6 C 1 M 2 4 M 2 6 C 3 C 4
 

Sample Output
  
  
1 0 2
 

Source
 

题目大意:

有N个砖头,编号为1~N,  然后有两种操作, 第一种是M  x  y,  把x所在的那一堆砖头全部移动放到y所在的那堆的上面。  第二种操作是C  x,  即查询x下面有多少个砖头,并且输出。


分析与总结:

带权并查集的应用, 用num数组来表示每一棵树的总数, rank[x]数组来表示x砖头下面有多少个砖头。

如果把a堆砖放到b堆砖上面, 那么a堆最底面那个砖头root_a的下面原本是有0个砖头的, 搬过去之后,变成了有b堆砖的数量个。然后root_a之上的数量便根据root_a的值进行更新。更新的步骤在查找时路径压缩的那一步进行。



代码:

#include<cstdio>

const int N = 30005;
int f[N];
long long rank[N],num[N];

inline void init(){
    for(int i=0; i<N; ++i)
        f[i]=i,rank[i]=0,num[i]=1;
}
int find(int x){
    if(x==f[x]) return f[x];
    int fa = f[x];
    f[x] = find(f[x]);
    if(rank[fa]!=0)
        rank[x] += rank[fa];
    return f[x];
}

inline void Union(int x,int y){
    int a=find(x), b=find(y);
    if(a==b) return ;
    rank[a] = num[b];
    f[a] = b;
    num[b] += num[a];
    num[a] = 0;
}

int main(){
    int t, x, y;
    char cmd[3];
    scanf("%d",&t);
    init();
    for(int i=0; i<t; ++i){
        scanf("%s",cmd);
        if(cmd[0]=='M'){
            scanf("%d%d",&x,&y);
            Union(x,y);
        }
        else{
            scanf("%d",&x);
            find(x);
            printf("%lld\n", rank[x]);
        }
    }
    return 0;
}


 
 

   
   

——  生命的意义,在于赋予它意义。

          
     原创 http://blog.csdn.net/shuangde800 , By   D_Double  (转载请标明)







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值