Description
Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.
Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.
Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.
Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.
Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?
Input
The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.
Output
For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.
Sample Input
2 2 2 0.9 0.9 1 0.9 0 0 0
Sample Output
0.972
概率+DP。
DP搞出来几次WA都是栽在计算概率的正确性上了。
碰巧给的例子对错误的计算也能给出正确解答。
概率P1 = 所有的队伍都解答对了至少一题。
概率P2 = 所有的队伍的解答题数都在1到N-1题之间。
这样要求的概率解为P1-P2。
数组p[i][j][k] 表示 第i支队伍前j道题目解答出k题。
这样队伍 i 解答对了至少一题的概率A[i] = p[i][M][1]+p[i][M][2]+...+p[i][M][M]。
队伍 i 解答题数在1到N-1之间概率B[i] = p[i][M][1]+p[i][M][2]+....+p[i][M][N-1]。
P1 = A[1]*A[2]*...*A[T]。
P2 = B[1]*B[2]*...*B[T]。
#include <stdio.h>
#include <stdlib.h>
#include <vector>
#include <list>
#include <set>
#include <time.h>
#include <string.h>
#include <string>
#include <iostream>
#include <map>
using namespace std;
#define M 31
#define T 1010
int m,t,n;
double p[T][M];
double f[T][M][M];
vector<double> res;
void process(){
double p_zero = 1;
double p_less = 1;
for(int i=1;i<=t;++i){
f[i][0][0] = 1;
for(int j=1;j<=m;++j)
f[i][j][0] = f[i][j-1][0]*(1-p[i][j]);
double sum1=0;
double sum2=0;
for(int k=1;k<=m;++k){
for(int j=1;j<=m;++j){
f[i][j][k] = f[i][j-1][k-1]*p[i][j] + f[i][j-1][k]*(1-p[i][j]);
}
sum1 += f[i][m][k];
if(k<n)
sum2 += f[i][m][k];
}
p_zero *= sum1;
p_less *= sum2;
}
res.push_back(p_zero-p_less);
}
int main(){
while(true){
scanf("%d %d %d",&m,&t,&n);
if(m==0 && t==0 && n==0)
break;
for(int i=1;i<=t;++i){
for(int j=1;j<=m;++j)
scanf("%lf",&p[i][j]);
}
process();
}
for(int i=0;i<res.size();++i)
printf("%.3f\n",res[i]);
//system("pause");
return 0;
}