Play on words (欧拉回路+并查集)

Play on words

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.
There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ‘acm’ can be followed by the word ‘motorola’.Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file.Each test case begins with a line containing a single integer number N that indicates the number of plates (1 ≤ N ≤ 100000). Then exactly N lines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will appear in the word. The same word may appear several times in the list.
Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence ‘Ordering is possible.’. Otherwise, output the sentence ‘The door cannot be opened.’

Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
Sample Output
The door cannot be opened.
Ordering is possible.
The door cannot be opened.
题意:给出一组单词,判断是否可以形成一组排列,使这组排列中的前一个单词的最后一个字母是后一个单词的第一个字母。所有单词都要用上,不分先后。
思路:可以把单词的两端当成图的两个端点,那么本题就是判断是否存在欧拉回路或欧拉通路。用并查集结合欧拉图的特性,可知只有一个祖先,且
1.各个节点的出入度相同,则有欧拉回路;
2.只有两个点的入度,出度不一样,且差值为1.则有欧拉通路
否则不成立

#include<stdio.h>
#include<string.h>
int f[110],in[110],out[110],book[110];
int find(int x){
	if(x!=f[x])
	    f[x]=find(f[x]);
	return f[x];
}
int main(){
	int t,n,i;
	scanf("%d",&t);
	while(t--){
		memset(in,0,sizeof(in));
		memset(out,0,sizeof(out));
		memset(book,0,sizeof(book));
		for(i=0;i<30;i++)//初始化 
		    f[i]=i;
		scanf("%d",&n);
		char s[1010];
		int len,a,b;
		for(i=0;i<n;i++){
			scanf("%s",s);
			len=strlen(s);
			a=find(s[0]-'a');
			b=find(s[len-1]-'a');
			if(a!=b)    f[b]=a;//并查集 
			in[s[0]-'a']++;//入度+1 
			out[s[len-1]-'a']++;//出度+1 
			book[s[0]-'a']=book[s[len-1]-'a']=1;//标记已出现 
		}
		int c=0,d=0,ans=0,flag=1,h=1;
		for(i=0;i<26;i++){
			if(book[i]){
				if(f[i]==i)    ans++;//找祖先 
				if(in[i]!=out[i]){//判断入度和出度之差 
					if(in[i]-out[i]==1)
					    c++;
					else if(out[i]-in[i]==1)
					    d++;
					else
					    h=0;
				}
				if(ans>1||h==0){
					flag=0;
					break;
				}
			}
		}
		if(flag&&h&&((!c&&!d)||(c==1&&d==1)))
		    printf("Ordering is possible.\n");
        else
            printf("The door cannot be opened.\n");
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值