Backward Digit Sums POJ3187

Backward Digit Sums
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6223 Accepted: 3602
Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:

3   1   2   4

  4   3   6

    7   9

     16

Behind FJ’s back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ’s mental arithmetic capabilities.

Write a program to help FJ play the game and keep up with the cows.
Input

Line 1: Two space-separated integers: N and the final sum.
Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.
Sample Input

4 16
Sample Output

3 1 2 4
Hint

Explanation of the sample:

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.
Source

USACO 2006 February Gold & Silver

题意:给1,2,…,n个数字,这些数字形成一个排列
a[0] a[1] a[2]
a[0]+a[1] a[1]+a[2]
sum=a[0]+a[1]+a[2]
依照如上的规律,运算出最后一个和sum,
现在给定n和sum,求出排列

思路:
暴力枚举出全排列
本来想贪心的,结果wa掉了

注意这几组数据
5 48
1 2 3 4 5
5 45
2 1 3 4 5
6 103
2 3 1 5 4 6
尤其是最后一组,会发现中间的部分无法简单的贪心,直接将数值小的数字放在前面是错误的写法。

#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
int n,sum;
bool vis[108];
int ans[108];
void help(int a,int b)
{
    ans[0]=a;
    ans[n-1]=b;
    int st=1;

    for(int i=1; i<n-1; i++)
    {
        while(a==st||b==st)
            st++;
        ans[i]=st++;
        //printf("  %d*%d  ",)
    }
}
int c(int a,int b)
{
    int  res=1;
    a=min(a,b-a);
    for(int i=0; i<a; i++)
    {
        res*=(b-a+i+1);
        res/=(1+i);
    }
    return res;
}
int main()
{
    while(scanf("%d%d",&n,&sum)!=EOF)
    {
        int all=0;
        all=(n+1)*n/2;
        // printf("n:%d\n",n);
        memset(vis,0,sizeof vis);

        help(1,n);
        do
        {
            int tmp=0;
            for(int i=0;i<n;i++)
            {
                tmp+=c(i,n-1)*ans[i];
            }
            if(tmp==sum)
                break;

        }while(next_permutation(ans,ans+n));

        for(int i=0; i<n; i++)
        {
            if(i)
                printf(" ");
            printf("%d",ans[i]);
        }
        puts("");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值