Hopscotch POJ3050

Hopscotch
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3284 Accepted: 2271
Description

The cows play the child’s game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).

Determine the count of the number of distinct integers that can be created in this manner.
Input

  • Lines 1..5: The grid, five integers per line
    Output

  • Line 1: The number of distinct integers that can be constructed
    Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1
Sample Output

15
Hint

OUTPUT DETAILS:
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.
Source

USACO 2005 November Bronze

题意 :给一个5X5的数字矩阵,问你一共可以组成几种5位数
思路:暴力枚举,set判重

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<set>
#include<string>

using namespace std;


int a[10][10];
set<int>se;
int ans;
int dx[]={0,0,1,-1};
int dy[]={1,-1,0,0};
void dfs(int x,int y,int tmp,int num)
{
    if(num>=5)
    {
        if(!se.count(tmp))
        {
           // printf("%d\n",tmp);
            se.insert(tmp);
            ans++;
        }
        return ;

    }
    for(int i=0;i<4;i++)
    {
        int xx,yy;
        xx=x+dx[i];
        yy=y+dy[i];
        if(xx>=0&&xx<5&&yy>=0&&yy<5)
        dfs(xx,yy,tmp*10+a[xx][yy],num+1);
    }

}
int main()
{
    se.clear();
    for(int i=0;i<5;i++)
    {
        for(int j=0;j<5;j++)
        {
            scanf("%d",&a[i][j]);
        }
    }

    for(int i=0;i<5;i++)
    {
        for(int j=0;j<5;j++)
        {
            dfs(i,j,a[i][j],0);
        }

    }
    printf("%d\n",ans);
    return 0;

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值