POJ-3050 Hopscotch(dfs)

The cows play the child’s game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).

Determine the count of the number of distinct integers that can be created in this manner.
Input

  • Lines 1…5: The grid, five integers per line
    Output
  • Line 1: The number of distinct integers that can be constructed
    Sample Input
    1 1 1 1 1
    1 1 1 1 1
    1 1 1 1 1
    1 1 1 2 1
    1 1 1 1 1
    Sample Output
    15
    Hint
    OUTPUT DETAILS:
    111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.
    题意分析:给你一个5*5的矩阵,求从任意一个位置出发,可以组成多少个不同的6位数
    解题思路:当找到第六个数字的时候,判断由这六个数字组成的整数是是否出现过。
    AC代码如下:
#include<stdio.h>
#include<string.h>
int sum,book[1000000];
int map[8][8];
//x,y为横纵坐标,t为当前是第几个数字,也就是走了第几步,count为由t个数字组成的整数
void dfs(int x,int y,int t,int count)
{
	int next[4][2]={{0,1},{0,-1},{1,0},{-1,0}},i,j,tx,ty;
	if(x<1||y<1||x>5||y>5)
		return;
	if(t==6)
	{
		if(book[count]==0)
		{
			sum++;
			book[count]=1;
		}
		return;
	}
	for(i=0;i<4;i++)
	{
		tx=x+next[i][0];
		ty=y+next[i][1];
		dfs(tx,ty,t+1,count*10+map[tx][ty]);
	}
}
int main()
{
	int i,j;
	sum=0;
	for(i=1;i<=5;i++)
		for(j=1;j<=5;j++)
			scanf("%d",&map[i][j]);
	for(i=1;i<=5;i++)
		for(j=1;j<=5;j++)
			dfs(i,j,1,map[i][j]);
	printf("%d\n",sum);
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值