1014 Waiting in Line (30分)--PAT甲级真题

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customeri will take Ti minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​ is served at window1 while customer2 is served at window2 Customer​3 will wait in front of window1 and customer4 will wait in front of window2 Customer5 will wait behind the yellow line.

At 08:01, customer​1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer​4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:
For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

题目类型:模拟题
题目大意:模拟银行排队,银行有多个窗口,每个窗口黄线内的等待区可以供人等待;用户选择黄线内等待人数最少的窗口,如果人数最少的窗口有多个,则选择编号最小的窗口;查询每个顾客结束服务的时间,如果开始服务的时间超过17:00,则输出sorry
分析:这个题目有点特殊性。虽然需要找排队队列最短的,但是呢,题目只给了到达的先后顺序,没有给出到达的时间点;所以前NM个人的排队次序是确定的。之后每个人,寻找最早结束服务的队列。
用队列queue来保存每个窗口前等待队列的信息;如果队列为空,服务开始时间为八点,否则,服务开始时间为前一个排队人员结束服务的时间。分别记录下客户开始服务和结束服务的时间

#include<iostream>
#include<queue> 
using namespace std; 
const int MAX = 123123123, START = 8 * 60, END = 17 * 60;
int N, M, K, Q;
int endT[1001],costT[1001],startT[1001];
queue<int> Que[21]; 
int selectW(){
	int ret, minlen = M, earT = MAX;
	for (int i = 0; i < N; i++){//黄线内还有位置,找最短的,如果长度一样找编号小的
		if (Que[i].size() < minlen){
			minlen = Que[i].size();
			ret = i;
		}
	}
	if (minlen < M)
		return ret;  
	for (int i = 0; i < N; i++){//黄线内没有位置,选择最早有位置的
		if (Que[i].front() < earT){
			earT = Que[i].front();
			ret = i;
		}
	}
	return ret;
} 
int main(){ 
	scanf("%d%d%d%d", &N, &M, &K, &Q); 
	for (int i = 1; i <= K; i++)
		scanf("%d", &costT[i]); 
	for (int i = 1; i <= K; i++){
		int w = selectW();
		if (Que[w].empty()) 
			startT[i] = START; 
		else 
			startT[i] = Que[w].back(); 
		endT[i] = startT[i] + costT[i]; 
		Que[w].push(endT[i]);
		if (Que[w].size() > M)
			Que[w].pop();
	} 
	for (int i = 0; i < Q; i++){
		int q;
		scanf("%d", &q);
		if (startT[q] >= END)
			cout << "Sorry\n";
		else
			printf("%02d:%02d\n", endT[q] / 60, endT[q] % 60);
	} 
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值