贪心算法 A

Farmer John has received a noise complaint from his neighbor, Farmer Bob, stating that his cows are making too much noise.

FJ’s N cows (1 <= N <= 10,000) all graze at various locations on a long one-dimensional pasture. The cows are very chatty animals. Every pair of cows simultaneously carries on a conversation (so every cow is simultaneously MOOing at all of the N-1 other cows). When cow i MOOs at cow j, the volume of this MOO must be equal to the distance between i and j, in order for j to be able to hear the MOO at all. Please help FJ compute the total volume of sound being generated by all N*(N-1) simultaneous MOOing sessions.
Input

  • Line 1: N

  • Lines 2…N+1: The location of each cow (in the range 0…1,000,000,000).
    Output
    There are five cows at locations 1, 5, 3, 2, and 4.
    Sample Input
    5
    1
    5
    3
    2
    4
    Sample Output
    40
    Hint
    INPUT DETAILS:

There are five cows at locations 1, 5, 3, 2, and 4.

OUTPUT DETAILS:

Cow at 1 contributes 1+2+3+4=10, cow at 5 contributes 4+3+2+1=10, cow at 3 contributes 2+1+1+2=6, cow at 2 contributes 1+1+2+3=7, and cow at 4 contributes 3+2+1+1=7. The total volume is (10+10+6+7+7) = 40.
做题思路:这道题主要是计算N头奶牛分别对N-1头奶牛的距离差之和,这题感觉和贪心没有多大关系,用递推关系就可以解决,先用sort将坐标从小到大排序,再根据f[i]=f[i-1]-(n-i)*(a[i]-a[i-1])+(n-2)*(a[i]-a[i-1]),只需先求出f[1],就可以递推求出我们所需的各个奶牛距离之和,最终相加即为我们所求的答案。

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
long long a[10010],f[10010];   //定义是一定要定义long long
int n;
long long ans=0;

int main(){
	cin>>n;
	for (int i=1;i<=n;i++)	scanf("%d",&a[i]);

	sort(a+1,a+n+1);//数组a从1开始输入也要从一开始排序

	for (int i=2;i<=n;i++) f[1]+=a[i]-a[1];    
	ans=f[1];//将f[1]罗列出来进行下面的递推

	for (int i=2;i<=n;i++){
		f[i]= f[i-1] - ((n-i)*(a[i]-a[i-1])) + (i-2)*(a[i]-a[i-1]);
		ans+=f[i];
	}
	cout<<ans<<endl;
	return 0;
}
``

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值