ACM:R: Optimal Parking
Description
When shopping on Long Street, Michael usually parks his car at some random location, and then walks to the stores he needs. Can you help Michael choose a place to park which minimises the distance he needs to walk on his shopping round?
Long Street is a straight line, where all positions are integer. You pay for parking in a specific slot, which is an integer position on Long Street. Michael does not want to pay for more than one parking though. He is very strong, and does not mind carrying all the bags around.
Input
The first line of input gives the number of test cases, 1<=t<=100. There are two lines for each test case. The first gives the number of stores Michael wants to visit, 1<=n<=20, and the second gives their n integer positions on Long Street, 0<=xi<=99.
Output
Output for each test case a line with the minimal distance Michael must walk given optimal parking.
Sample Input
2 4 24 13 89 37 6 7 30 41 14 39 42
Sample Output
152 70
注:不管在哪里停车,都需要把商店转一遍,并且再回到车中,即最大位置商店到最小位置商店距离的两倍。
#include <iostream>#include <cstdio>#include <cstring>#include <vector>#include <cmath>#include <algorithm>#include <string>using namespace std;#define N 22int store[N];int cmp(const void *a,const void *b){return (*(int *)a-*(int *)b);}int main(){int T,n;cin>>T;
while(T--){
cin>>n;
for(int i=0;i<n;i++){
cin>>store[i];
}
qsort(store,n,sizeof(store[0]),cmp);cout<<store[n-1]*2-store[0]*2<<endl;}
return 0;}