poj 3632 Optimal Parking

Optimal Parking
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8017 Accepted: 4893

Description

When shopping on Long Street, Michael usually parks his car at some random location, and then walks to the stores he needs. Can you help Michael choose a place to park which minimises the distance he needs to walk on his shopping round? Long Street is a straight line, where all positions are integer. You pay for parking in a specific slot, which is an integer position on Long Street. Michael does not want to pay for more than one parking though. He is very strong, and does not mind carrying all the bags around.

Input

The first line of input gives the number of test cases, 1 ≤ t ≤ 100. There are two lines for each test case. The first gives the number of stores Michael wants to visit, 1 ≤ n ≤ 20, and the second gives their n integer positions on Long Street, 0 ≤ xi ≤ 99.

Output

Output for each test case a line with the minimal distance Michael must walk given optimal parking.

Sample Input

2
4
24 13 89 37
6
7 30 41 14 39 42

Sample Output

152
70

Source




题意很复杂还以为是图,其实就是在一条数轴上设立很多个点,从哪个点开始走在回来并且能遍历所有的点然后求最短距离

就是从最近的点走到最远的点再回来.....



#include<iostream>
#include<cstring>
using namespace std;
int n;
int main(){
	int t;
	cin>>t;
   while(t--){
      cin>>n;
      int a;
      cin>>a;
      int min1=a;
      int max1=a;
      for(int i=2;i<=n;i++)
      {
      	cin>>a;
        if(min1>a)min1=a;
        if(max1<a)max1=a;
	  }
	  int ans=max1-min1;
	  cout<<ans*2<<endl;
   }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值