Euler is a well-known matematician, and, among many other things, he discovered that the formula
n2 + n + 41 produces a prime for 0 ≤ n < 40. For n = 40, the formula produces 1681, which is 41 ∗ 41.
Even though this formula doesn’t always produce a prime, it still produces a lot of primes. It’s known
that for n ≤ 10000000, there are 47,5% of primes produced by the formula!
So, you’ll write a program that will output how many primes does the formula output for a certain
interval.
Input
Each line of input will be given two positive integer a and b such that 0 ≤ a ≤ b ≤ 10000. You must
read until the end of the file.
Output
For each pair a, b read, you must output the percentage of prime numbers produced by the formula in
this interval (a ≤ n ≤ b) rounded to two decimal digits.
Sample Input
0 39
0 40
39 40
Sample Output
100.00
97.56
50.00
题意是让你按着他个n*n+n+41的公式去判断答案结果是否是个素数,然后给你一个区间,让你输出根据这个公式判断出来的质数的概率。
然后就是结果加1e-8,是一个非常小的double型数据,据说是防止精度损失,不加就错.
代码如下
#include<stdio.h>
#include<math.h>
int f[10005];
int aaa(int n)//判断素数
{
int i;
for(i=2;i<=sqrt(n);i++)//n的素数中小的哪一个比根号n还要小
{
if(n%i==0)
return 0;
}
return 1;
}
int main()
{
int i,a,b;
for(i=0;i<=10000;i++)
f[i]=aaa(i*i+i+41);
while(~scanf("%d%d",&a,&b))
{
double sum=0;
for(i=a;i<=b;i++)
sum=sum+f[i];
printf("%.2f\n",sum/(b-a+1)*100+1e-8);//共有b-a+1个数
}
return 0;
}