HDU 2356 Find a multiple(鸽巢原理)

Find a multiple

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8367 Accepted: 3636 Special Judge

Description
The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input
The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output
In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3

Source
Ural Collegiate Programming Contest 1999


题意:给出一个数n,输入n个数,找出连续排列的一串数字,满足为n的倍数,输出数字串长度和数字串,每个数字一行。


鸽巢原理的入门题,水,但是错了很多次,看了模版,细节问题,找了很久bug。。。
暴力还容易一些~


鸽巢简单理解就是:假如有n+1只鸟,有n个巢,这些鸟都回巢,那么肯定有一个巢的鸟多于两只。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 11111
int n, i, j;
int a[N] = {0}, b[N] = {0}, vis[N];
void run()
{
    memset( vis, -1, sizeof( vis ));
    vis[0] = 0;
    for( i = 1 ; i <= n ; i ++ ){///
        if( vis[b[i]] == -1 )
            vis[b[i]] = i;
        else{
            cout<<i-vis[b[i]]<<endl;///
            for( j = vis[b[i]]+1; j <= i ; j ++ ){
                cout<<a[j]<<endl;
            }
            return;
        }
    }
}
int main()
{
    //freopen( "in.txt", "r", stdin );
    scanf( "%d", &n );
    for( i = 1 ; i <= n ; i ++ ){///从1开始输入,上面容易输出
        scanf( "%d", &a[i] );
    }
    //b[0] = a[0] % n;///
    b[0] = a[0] = 0;
    for( i = 1 ; i <= n ; i ++ ){
        b[i] = (a[i] + b[i-1]) % n;
    }
    run();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值