4 Values whose Sum is 0 poj-2785(四个长度为4000的数组,从每个数组中取出一个数,使取出的四个数和为0 二分优化)

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2  28 ) that belong respectively to A, B, C and D .
Output
For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5
Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

思路: 看到数组长度,三层循环一定超时,你怎么能优化呢, 好好学学吧,在这里用到了二分优化,两个函数,upper_bound(),lower_bound();

先把 c和d数组的所有可能数的和,算出来,放到一个数组中,再把这个数组排序,在枚举a和b数组的和,再在排好序的数组中用二分算法找;

upper_bound(); 返回第一个大于 k(要查找的数字)的数字的位置;

lower_bound(); 返回第一个等于k的数字位置,或返回第一个大于k数字的位置;


代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define Max 4040
#define ll long long 
ll  a[Max],b[Max],c[Max],d[Max];
int n; 
ll  tt[Max*Max];

int main()
{
	int i,j;
	while(~scanf("%d",&n))
	{
		for(i = 0;i<n;i++)
			scanf("%lld%lld%lld%lld",&a[i],&b[i],&c[i],&d[i]);
		int sum = 0;
		for(i = 0;i<n;i++)
			for(j = 0;j<n;j++)
				tt[sum++] = c[i]+d[j];
		sort(tt,tt+sum);
		ll res = 0;
		for(i = 0;i<n;i++)
		{
			for(j = 0;j<n;j++)
			{
				ll k = a[i]+b[j];
				res += upper_bound(tt,tt+sum,-k) - lower_bound(tt,tt+sum,-k);
			}
		}
		printf("%lld\n",res);
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值