POJ-2785 4 Values whose Sum is 0(二分)

POJ-2785 4 Values whose Sum is 0(二分)

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .
Output
For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5
Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
#include<cstdio>  
#include<iostream>  
#include<cstring>  
#include<algorithm>  
using namespace std;  
int a[4002][4],sum1[16000002],sum2[16000002];  
int main()  
{  
    int n,mid;
    int i,j;
    scanf("%d",&n);    
        for(i=0;i<n;i++)   
        scanf("%d%d%d%d",&a[i][0],&a[i][1],&a[i][2],&a[i][3]);  
        int k=0;  
        int m=0;  
        for(i=0;i<n;i++)  
        for(j=0;j<n;j++)  
        {  
            sum1[k++]=a[i][0]+a[j][1];   //这样k就记了数 ,i<k,就很好
            sum2[m++]=a[i][2]+a[j][3];  //这样由n^4变成n^2.
        }  
        sort(sum2,sum2+k);  //可能是二分也强调单调性,之前没有注意到
        int cnt=0;  
        for(i=0;i<k;i++)  
        {  
           int left=0;  
           int right=k-1;  //这个right真是神来之笔。 极度的简化。
          while(left<right)  
          {  
            mid=(left+right)/2;  
            if(sum1[i]+sum2[mid]==0) //left,right竟变成j的下标,啊啊啊啊
            {                        //并且可以发现一个i,是对应二分的多种情况
                cnt++;  
                for(j=mid+1;j<k;j++)  
                {  
                    if(sum1[i]+sum2[j]!=0) // j=mid+1,是因为sum2存在相等的情况,
                    break;  
                    else  
                    cnt++;  
                }  
                for(j=mid-1;j>=0;j--) //同上  
                {  
                    if(sum1[i]+sum2[j]!=0)  
                    break;  
                    else  
                    cnt++;  
                }  
                    break; //统计了相等情况,就满足了这个功能
            }  
                    if(sum1[i]+sum2[mid]<0)  
                    left=mid+1;  
                    else  
                    right=mid;  //这里的二分:显然,因为之前有过排序
          }  
        }  
            printf("%d\n",cnt);    
        return 0;  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值