POJ2151 概率题

Check the difficulty of problems
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 4684 Accepted: 2050

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 
1. All of the teams solve at least one problem. 
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems? 

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

ACM有T支队伍,共有M道题,给出每支队伍A出每到题目的概率,求所有队伍至少A出一道而且第一名至少A出N道,注意有可能并列第一。

令事件A:每支队伍至少算出一道题的概率。

    B:至少有一支队伍A出至少N道题目。

那么P(AB)=P(A)-P(A(~B));

用dp[i][j][k]表示,第i支队伍在前j题A出k道题目。p[i][j][k]=p[i][j-1][k]*(1-a[i][j])+p[i][j-1][k-1]*a[i][j];

AC代码:


#include <iostream>
#include <cmath>
#include <stdio.h>
#include <algorithm>
#include <ctime>
#include <vector>
#include <cstring>
#include <map>
#include <string>
#include <queue>
//#include <fstream>
using namespace std;
#define LL long long
#define ULL unsigned long long
//#define REP(i,n) for(int i=0;i<n;++i)
#define REP(i,a,b) for(int i=a;i<=b;++i)
#define INFLL (1LL)<<62
#define mset(a) memset(a,0,sizeof a)
#define FR(a) freopen(a,"r",stdin)
#define FW(a) freopen(a,"w",stdout)
#define PI 3.141592654
const LL MOD = 1000000007;
const int M=33;
const int maxn=1002;
int m,n,t;
double p[maxn][M][M];
double a[maxn][M];
int main()
{
	while (cin>>m>>t>>n,m)
	{
		mset(p);
		REP(i,1,t){
			REP(j,1,m)
				scanf("%lf",a[i]+j);
			p[i][0][0]=1;
			REP(j,1,m){
				p[i][j][0]=p[i][j-1][0]*(1-a[i][j]);
				REP(k,1,j){
					p[i][j][k]=p[i][j-1][k]*(1-a[i][j])+p[i][j-1][k-1]*a[i][j];

				}
			}
		}
		double ans=0,ab_=1,a=1;
		REP(i,1,t)
		{
			double temp=0;
			REP(j,1,n-1)
				temp+=p[i][m][j];
			ab_*=temp;
			a*=1-p[i][m][0];
		}
		ans=a-ab_;
		printf("%.3lf\n",ans);
	}
}

WA代码:


#include <iostream>
#include <cmath>
#include <stdio.h>
#include <algorithm>
#include <ctime>
#include <vector>
#include <cstring>
#include <map>
#include <string>
#include <queue>
//#include <fstream>
using namespace std;
#define LL long long
#define ULL unsigned long long
//#define REP(i,n) for(int i=0;i<n;++i)
#define REP(i,a,b) for(int i=a;i<=b;++i)
#define INFLL (1LL)<<62
#define mset(a) memset(a,0,sizeof a)
#define FR(a) freopen(a,"r",stdin)
#define FW(a) freopen(a,"w",stdout)
#define PI 3.141592654
const LL MOD = 1000000007;
const int M=33;
const int maxn=1002;
int m,n,t;
double p[maxn][M][M];
double a[maxn][M];
int main()
{
	while (cin>>m>>t>>n,m)
	{
		mset(p);
		REP(i,1,t){
			REP(j,1,m)
				scanf("%lf",a[i]+j);
			p[i][0][0]=1;
			REP(j,1,m){
				p[i][j][0]=p[i][j-1][0]*(1-a[i][j]);
				REP(k,1,j){
					p[i][j][k]=p[i][j-1][k]*(1-a[i][j])+p[i][j-1][k-1]*a[i][j];

				}
			}
		}
		double ans=0,ab_=1,a=1;
		REP(i,1,t)
		{
			p[i][m][1]=1-p[i][m][0];
			REP(j,n+1,m)
				p[i][m][n]+=p[i][m][j];
			ab_*=(p[i][m][1]-p[i][m][n]);
			a*=p[i][m][1];
		}
		ans=a-ab_;
		printf("%.3lf\n",ans);
	}
}

然后我不知道为什么后面的代码会WA,不知道是不是精度问题,有大神路过请帮忙解答下。




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值