POJ1837-Balance

1 篇文章 0 订阅

Gigel has a strange “balance” and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm’s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.
Input
The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-’ for the left arm and ‘+’ for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights’ values.
Output
The output contains the number M representing the number of possibilities to poise the balance.
Sample Input
2 4
-2 3
3 4 5 8
Sample Output
2

题意:第一行给出n个钩子,m个砝码,接下来是n个钩子的位置,然后m个砝码的重量。问有几种方法能让砝码全部挂在钩子上且天平平衡。
思路:naive 20^20暴搜? 做这题的时候想起了同济惨案2333类似题我直接暴搜了一发。比赛之后问强神怎么做233说用背包。做这题的时候就直接想到了背包。感觉这题还是个加强版,因为有钩子位置的问题所以每个砝码的权值有n种背包权值。每个砝码只能挂一次,但是权值有许多种,所以我们必须开二维背包。就相当于对第i个砝码的第j种权值和第i个砝码的第j+1种权值都是从第i-1个砝码得到的各个方案数转移过来的。
具体处理的时候为了避免出现负数,我们把所有权值同时加上最小值的绝对值这样平移范围可以避免负数出现。

#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<vector>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<string>
#include<stack>
#include<map>
#include<set>
using namespace std;

//thanks to pyf ...
//thanks to qhl ...

#define INF 0x3f3f3f3f
#define CLR(x,y) memset(x,y,sizeof(x))
#define mp(x,y) make_pair(x,y)
typedef pair<int, int> PII;
typedef long long ll;

const int N = 1e5 + 5;

int dp[30][N];
int mul[N], w[N];

int main()
{
    int n, m;
    while (cin >> n >> m)
    {
        for (int i = 1; i <= n; i++)
            cin >> mul[i];
        for (int i = 1; i <= m; i++)
            cin >> w[i];
        CLR(dp, 0);
        dp[0][7500] = 1;
        for (int i = 1; i <= m; i++)
        {
            for (int k = 1; k <= n; k++)
            {
                int cur = mul[k] * w[i];
                for (int j = 15000; j >= cur; j--)
                    dp[i][j] += dp[i - 1][j - cur];
            }
        }
        cout << dp[m][7500] << endl;
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值