PTA_PAT甲级_1076 Forwards on Weibo (30分)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:
For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

题意:
每个用户能看到自己关注的用户发的微博,分别给出N个用户关注的对象,和K个需查询的用户,分别输出这些用户发一条微博在L层内最多可能有多少次转发(假设看到就会转发并每个人只转发一次)

分析:
与层有关的遍历用BFS更适合

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<vector> 
#include<queue>
using namespace std;

#define MAXV 1020
struct Node{
	int id;//节点编号 
	int layer;//节点层号 
};
vector<Node> Adj[MAXV];//邻接表
bool inq[MAXV] = {false};//顶点是否已被加入过队列 

int BFS(int s, int L){//start为起始节点,L为层数上限 
	int numForward = 0;//转发数 
	queue<Node> q;//BFS队列 
	Node start;//定义起始节点
	start.id = s;//起始节点编号
	start.layer = 0;//起始节点层号为0
	q.push(start);//将起始节点压如队列
	inq[start.id] = true;//起始节点编号设为已加入队列
	while(!q.empty()){
		Node topNode = q.front();//取出队首节点
		q.pop();//队首节点出队
		int u = topNode.id;//队首节点的编号
		for(int i=0;i<Adj[u].size();i++){
			Node next = Adj[u][i];//从u出发能到达的节点next
			next.layer = topNode.layer + 1;//next的层号等于当前节点层号加1
			//如果next的编号未被加入过队列,且next的层次不超过上限L
			if(inq[next.id]==false && next.layer<=L){
				q.push(next);
				inq[next.id] = true;//next的编号设为已加入过队列
				numForward++;//转发数加1 
			} 
		} 
	} 
	return numForward; 
} 

int main()
{
    Node user;
    int N, L, numFollow, idFollow;
    cin>>N>>L;
    for(int i=1;i<=N;i++){
    	user.id = i;
    	cin>>numFollow;
    	for(int j=0;j<numFollow;j++){
    		cin>>idFollow;
    		Adj[idFollow].push_back(user);//边idFollow->i 
		}
	}
	int numQuery, s;
	cin>>numQuery;//查询个数 
	for(int i=0;i<numQuery;i++){
		memset(inq, false, sizeof(inq));//inq数组初始化
		cin>>s;
		int numForward = BFS(s, L);
		cout<<numForward<<endl; 
	} 
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

hqy_240603

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值