hdu 1081To The Max(二维最大连续子串和)

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6994    Accepted Submission(s): 3375


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
  
  
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
  
  
15
 


题目大意:给你一个n*n的矩阵,让你找一个子矩阵,使得这个矩阵内所有数字的和最大。

    解题思路:先联系一维的最大连续子串和,dp[i]=max(dp[i-1],0)+a[i]其中dp[i]表示前面i项内所取得的最大值,必须包含第i项。a[i]表示第i项。这个二维矩阵的题目也可以进行转换。先用mp[i][j],表示第i行前j列的和。那么状态转移方程可以转换为dp[k]=max(dp[k-1],0)+a[k],我们可以将a[k]看作第j列到第i列的第k项的和,a[k]=mp[k][i]-mp[k][j-1].

     题目地址:To The Max

AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

int mp[105][105];

int main()
{
    int i,j,k,res,n,x;
    while(cin>>n)
    {
        res=-1e9;
        memset(mp,0,sizeof(mp));
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
            {
                scanf("%d",&x);
                mp[i][j]=mp[i][j-1]+x;
            }

        for(i=1;i<=n;i++)
        {
            for(j=1;j<=i;j++)    //从第j列到第i列
            {
                int tmp=-1;
                for(k=1;k<=n;k++)   //看成一维的 dp[k]=max(dp[k-1],0)+a[k]
                {
                    tmp=max(tmp,0)+mp[k][i]-mp[k][j-1];
                    res=max(res,tmp);
                }
            }
        }

        cout<<res<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值