hdu 5534 Partial Tree

22 篇文章 0 订阅


Partial Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1045    Accepted Submission(s): 523


Problem Description
In mathematics, and more specifically in graph theory, a tree is an undirected graph in which any two nodes are connected by exactly one path. In other words, any connected graph without simple cycles is a tree.

You find a partial tree on the way home. This tree has  n  nodes but lacks of  n1  edges. You want to complete this tree by adding  n1  edges. There must be exactly one path between any two nodes after adding. As you know, there are  nn2  ways to complete this tree, and you want to make the completed tree as cool as possible. The coolness of a tree is the sum of coolness of its nodes. The coolness of a node is  f(d) , where  f  is a predefined function and  d  is the degree of this node. What's the maximum coolness of the completed tree?
 

Input
The first line contains an integer  T  indicating the total number of test cases.
Each test case starts with an integer  n  in one line,
then one line with  n1  integers  f(1),f(2),,f(n1) .

1T2015
2n2015
0f(i)10000
There are at most  10  test cases with  n>100 .
 

Output
For each test case, please output the maximum coolness of the completed tree in one line.
 

Sample Input
  
  
2 3 2 1 4 5 1 4
 

Sample Output
  
  
5 19
 

Source
 

Recommend
hujie
 

Statistic |  Submit |  Discuss |  Note
题意:给你n个点,然后再给f(d)表示一个点有d个度,价值为f(d),让你建一棵树后,所有点的价值和最大。

思路:能看出度的总和是个定值,等于2*n-2,然后有n-1个d每个d价值为f(d),很明显可以看出是个无限背包问题,直观思维是想到dp[i][j]表示已用i个度分配了j个点,答案就是dp[n*2-2][n],但是这种想法的时间复杂度是O(n^3),所以我们可以先每个点分配1度,那么就剩下n-2度了,然后就化简成体积为n-2求最大价值的无限背包问题。时间复杂度为O(n^2)。下面给代码:

#include<set>
#include<map>
#include<ctime>
#include<cmath>
#include<stack>
#include<queue>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
typedef long long LL;
using namespace std;
#define inf 0x3f3f3f3f
#define maxn 2200
typedef long long LL;
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        int value[maxn];
        LL dp[maxn]={0};
        for(int i=1;i<n;i++){
            scanf("%d",&value[i]);
        }
        dp[0]=n*(LL)value[1];
        for(int i=1;i<=n-2;i++){
            for(int j=1;j<=i;j++){
                dp[i]=max(dp[i],dp[i-j]+value[j+1]-value[1]);
            }
        }
        printf("%lld\n",dp[n-2]);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值