HDU 5655 CA Loves Stick(四根棍子能否拼成四边形)

题目:

Problem Description
CA loves to play with sticks.
One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral.
(What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)
 

Input
First line contains   T  denoting the number of testcases.
T  testcases follow. Each testcase contains four integers   a,b,c,d  in a line, denoting the length of sticks.
1T1000, 0a,b,c,d2631
 

Output
For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).
 

Sample Input
  
  
2 1 1 1 1 1 1 9 2
 

Sample Output
  
  
Yes No
 

题解:

组成四边形的条件就是任意3边之和大于第4边,注意0的情况。

long long数据可能会爆 ,用unsigned long long  会比较好。


代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
    int t;
    int a[1005];
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        double pro;
        pro=0;

        for(int i=1;i<=n;i++)
        {
            double count=0;
            for(int j=1;j<=n;j++)
            {
                if(a[i]>a[j]) count++;
            }

            pro+=(count/(n-1))/n;
        }
    printf("%.6f\n",pro);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值