贪心 hero

题目:

Description

When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN. 

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS. 

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds. 

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
 

Input

The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)
 

Output

Output one line for each test, indicates the minimum HP loss.
 

Sample Input

        
        
1 10 2 2 100 1 1 100
 

Sample Output

        
        
20 201
 

题解:

有N个敌方英雄,我方一个英雄,dps为1,hp无限,求消灭敌方所有英雄承受的最少伤害。
开一个结构体数组,struct hero{int dps;int hp;}a[105];
将元素按下列式子从小到大排序: 
 (((a.dps+b.dps)*a.hp+b.dps*b.hp) < ((a.dps+b.dps)*b.hp+a.hp*a.dps))
可得应先消灭哪个英雄,最后计算承受总伤害。


代码:

#include <stdio.h>
#include <algorithm>
#include <math.h>
using namespace std;
struct hero
{
    int dps;
    int hp;
}a[105];
bool cmp(hero a,hero b)
{
     return  (((a.dps+b.dps)*a.hp+b.dps*b.hp) < ((a.dps+b.dps)*b.hp+a.hp*a.dps));
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        int sum=0;
        long long int loss;
        loss=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d %d",&a[i].dps,&a[i].hp);
            sum+=a[i].dps;
        }
        sort(a,a+n,cmp);
        for(int i=0;i<n;i++)
        {
            loss+=a[i].hp*sum;
            sum-=a[i].dps;
        }
        printf("%lld\n",loss);
    }
    return 0;
}






  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值