UVA 11401 Triangle Counting

Question:
You are given n rods of length 1, 2, … , n. You have to pick any 3 of them and build a triangle. How
many distinct triangles can you make? Note that, two triangles will be considered different if they have
at least 1 pair of arms with different length.
Input
The input for each case will have only a single positive integer n (3 ≤ n ≤ 1000000). The end of input
will be indicated by a case with n < 3. This case should not be processed.
Output
For each test case, print the number of distinct triangles you can make.
Sample Input
5
8
0
Sample Output
3
22
题意大意:输入一个数,求1~n能组成边长各不相等三角形的个数。
思路:令x为最大的边为x,z的取值范围(x-y,x)开区间。解得得到0,1,2,3,,,x-2得到和(x-1)(x-2)/2。但其中有y=z的三角形,取值从(x-1)/2~(x+x-1)/2,其中共有x-1项,但每两项的值是相同的,例如4/2==5/2,所以共有(n-1)/2项y==z,。但总的三角形都被算了两遍。所以sum[n]=sum[n-1]+((n-1)(n-2)/2-(n-1))/2

#include <iostream>
#include <cstdio>
using namespace std;
typedef long long LL;
const int Max=1000005;
LL a[Max];
int main()
{
    LL n,i;
    a[3]=0;
    for(i=4;i<Max;i++)
        a[i]=a[i-1]+((i-2)*(i-1)/2-(i-1)/2)/2;
    while(1)
    {
        scanf("%lld",&n);
        if(n<3)
            break;
        printf("%lld\n",a[n]);
    }
    return 0;
}

体会:灵活运用递推。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值