The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
Input
There are several test cases. Each line has two integers a, b (2<a<b<3000000).
Output
Output the result of (a)+ (a+1)+....+ (b)
Sample Input
3 100
Sample Output
3042
定义:对于正整数n,φ(n)是小于或等于n的正整数中,与n互质的数的数目。
核心就是当m%p==0:
f(m*p) = f(m) * p;//因为(p-1)是在f(m)中所以是乘p;
否则:
f(m*p) = f(m) * (p-1);
代码一:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn=3000001;
int phi[maxn],prime[216818];
bool a[maxn];
void isprime()
{
int i,j,k;
k=0;
for(i=2;i<maxn;i++){
if(!a[i]){
prime[k++]=i;
phi[i]=i-1;
}
for(j=0;j<k&&i*prime[j]<maxn;j++){
a[prime[j]*i]=1;
if(i%prime[j])
phi[i*prime[j]]=phi[i]*(prime[j]-1);
else{
phi[i*prime[j]]=phi[i]*prime[j];
break;
}
}
}
}
代码二:
int main()
{
int a,b,i;
LL sum;
isprime();
while(~scanf("%d%d",&a,&b)){
sum=0;
for(i=a;i<=b;i++)
sum+=phi[i];
printf("%I64d\n",sum);
}
return 0;
}
#include<stdio.h>
#define N 3000005
int phi[N];
int euler()
{
int i,j;
for(i=1;i<=N;i++)
phi[i]=i;
for(i=2;i<=N;i++)
{
if(phi[i]==i)
{
for(j=i;j<=N;j+=i)
{
phi[j]=phi[j]/i*(i-1);
}
}
}
}
int main()
{
int a,b;
long long sum;
euler();
while(scanf("%d%d",&a,&b)!=EOF)
{
sum=0;
for(int i=a;i<=b;i++)
{
sum+=phi[i];
}
printf("%lld\n",sum);
}
}