poj 3984 迷宫问题打印路径模板

迷宫问题
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions:28201 Accepted: 16264

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
using namespace std;
const int maxn = 5;
int sx,sy;
bool vis[maxn][maxn];
int dir[4][2] = {0,1,0,-1,1,0,-1,0};
int mapp[maxn][maxn];
int ans = 0;
struct Pos
{
    Pos(int x,int y)
    {
        this->x =x;
        this->y = y;
    }
    int x;
    int y;
};
stack<Pos>path;
stack<Pos>path1;
struct node
{
    int x,y;
    node(int a,int b):x(a),y(b) {}
};
struct road
{
    int x,y,step;
    vector<node>v;
};

int check(int x,int y)
{
    if(x<0||x>4||y<0||y>4)
        return 1;
    if(vis[x][y] || mapp[x][y]==1)
        return 1;
    return 0;
}

queue<node>q1;
queue<node>q2;
void bfs()
{
    road a,next;
    queue<road>Q;
    a.x = 0;
    a.y = 0;
    a.step = 0;
    Q.push(a);
    vis[a.x][a.y]=true;
    a.v.push_back(node(0,0));
    while(!Q.empty())
    {
        a = Q.front();
        Q.pop();
        if(a.x==4&&a.y==4)
        {
            ans = a.step;
            for(int i=0; i<a.v.size(); i++)
            {
                path.push(Pos(a.v[i].x,a.v[i].y));
            }
            return;
        }
        for(int i=0; i<4; i++)
        {
            next = a;
            next.x += dir[i][0];
            next.y += dir[i][1];
            if(check(next.x,next.y))
                continue;
            next.step = a.step+1;
            vis[next.x][next.y] = 1;
            next.v.push_back(node(next.x,next.y));
           // q1.push(next);
            Q.push(next);
        }
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    for(int i=0; i<maxn; i++)
        for(int j=0; j<maxn; j++)
            cin>>mapp[i][j];
    memset(vis,false,sizeof(vis));
    bfs();
    while (!path.empty())
    {
        Pos pos = path.top();
        path1.push(pos);
        path.pop();
    }
    cout<<"(0, 0)"<<endl;
    while(!path1.empty())
    {
        Pos pos = path1.top();
        cout<<"("<<pos.x<<", "<<pos.y<<")"<<endl;
        path1.pop();
    }

    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值