Farthest Nodes in a Tree(树的直径)

Farthest Nodes in a Tree
Time Limit: 2000 MS      Memory Limit: 32768 KB      64bit IO Format: %lld & %llu

Description

Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000) denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

Output

For each case, print the case number and the maximum distance.

Sample Input

2

4

0 1 20

1 2 30

2 3 50

5

0 2 20

2 1 10

0 3 29

0 4 50

Sample Output

Case 1: 100

Case 2: 80


介个题就是求树的直径,但是自己还是不理解,没弄明白,代码不AC。
测试样例都过了,还找不到原因。。。。。

错误代码:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <queue>
#define M 30000+10

using namespace std;

struct Edge{
	int from,to,val,next;
};
Edge edge[M*4];
int head[M];//每一个节点的头位置 
int edgenum;//总边数 
int u,v,w,n;
int ans;    //最后结果 
int tnode;  //记录S-T的端点 
int dist[M];//以该点结尾的最长路 
bool vis[M];//标记节点是否被访问 

void init(){
	memset(head,-1,sizeof(head));
	tnode=0;edgenum=0;
}

void addeage(int u,int v,int w)
{
	edge[edgenum].from=u;
	edge[edgenum].to=v;
	edge[edgenum].val=w;
	edge[edgenum].next=head[u];
	head[u]=edgenum;
	edgenum++;
}

void BFS(int s)
{
	ans=0;
	memset(dist,0,sizeof(dist));
	memset(vis,false,sizeof(vis));
	queue<int > q;
	vis[s]=true;dist[s]=0;ans=0;
	q.push(s);
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		for(int i=head[u];i!=-1;i=edge[i].next)
		{
			int v=edge[i].to;
			if(!vis[v])
			{
				if(dist[v]<dist[u]+edge[i].val)
				{
					dist[v]=dist[u]+edge[i].val;
				}
				vis[v]=true;
				q.push(v);
			}
		}
	}
	for(int i=0;i<n;i++)
	{
		if(ans<dist[i])
		{
			ans=dist[i];
			tnode=i;
		}
	}
}

int main()
{
	int t,k=0;
	scanf("%d",&t);
	while(t--)
	{
		init();
		scanf("%d",&n);
		for(int i=1;i<n;i++)
		{
			scanf("%d%d%d",&u,&v,&w);
			addeage(u,v,w);
			addeage(v,u,w);
		}
		BFS(0);
		BFS(tnode);
		printf("Case %d: %d\n",++k,ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值